crash if I try to customize Toolbar

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Noichigo_Kaze, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050725 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050725 SeaMonkey/1.0a

I use Mac OS 10.4.1 and Thunderbird 1.0+ (20050724).
Thunderbird crashes if I try to customize Toolbar.
If I try to move "Print" button from Toolbar to the "Customize Toolbar" panel
Thunderbird always crashes.

Reproducible: Always

Steps to Reproduce:
1. select "Customize..." from "Toolbar" in the "View" menu
2. move "Print" button from Toolbar to the "Customize Toolbar" panel
3.
Actual Results:  
Thunderbird crashes.

Expected Results:  
I can move "Print" button from Toolbar to the "Customize Toolbar" panel without
crash and can customize Toolbar.
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

13 years ago
hmm this worked for me on the 07/25 mac nightly.
(Reporter)

Comment 2

13 years ago
I use Mac OS 10.4.2, not 10.4.1. Sorry.

I can customize Toolbar if I move "Junk" button from Toolbar to the "Customize
Toolbar" panel first and then move "Print" button.
However if I move "Print" button first Thunderbird always crashes.
(Reporter)

Comment 3

13 years ago
On the Thunderbird 1.0+ (20050728), it doesn't crash when I move "Print" button from Toolbar to the 
"Customize Toolbar" panel.
However, if I push "Restore Default Set" button on "Customize Toolbar" panel and close the panel, then I 
cannot select anything in "View" menu because everything is gray out. 
And then, when I quit Thunderbird, it always crashes.

Comment 4

13 years ago
I'm seeing the same thing with 1.5rc2 on Linux/X.  Reliable repro case is to right-click the toolbar, choose Customize, and drag the Junk icon from the toolbar to the Customize dialog.  The icon moves, then TB generates a Talkback about 2 seconds later.
QA Contact: front-end

Comment 5

11 years ago
WFM version 2.0.0.6 (20070728) and trunk.
please comment if  you see otherwise.
=> WORKSFORME
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: crash
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.