IBM Remote Supervisor Adapter Remote Control Crashes Firefox

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: jbebel, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-12-10, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U;Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

The IBM Remote Supervisor Adapter has an IP KVM built into it, which loads a
java applet to control my IBM server.  The first time this page loads, it
usually works fine.  The second time it loads, a few seconds later, firefox just
quits with no explanation.  In windows, when this happens, the remote control
pop-up window continues to operate, but the main window hangs.  I believe this
to be partially a bug in the RSA card, but firefox doesn't seem to be handling
it very well either.

While this isn't happening on a public web page, I can provide ethereal dumps of
the problem, and perhaps provide access to the interface to a trusted Firefox
developer.

Reproducible: Sometimes

Steps to Reproduce:
1.Log into RSA card
2.Select remote control and start one of the remote control interfaces.
3.Close the interface.
4.Start the interface again

Actual Results:  
Firefox disappears as if I killed it.  Again, in windows, the main window of
Firefox hangs, although the remote ocntrol window java applet still operates.

Expected Results:  
Firefox should continue to run.  If I was lucky, some error message would show
up, but at the very least it should just not show a web page result.  But
crashing is never the intended result.

No error given when firefox crashes.  If there is a debugging option I should
provide it on the console I'd be happy to give the result.
(Reporter)

Comment 1

12 years ago
The ethereal dump I have of this problem is too large to upload as an
attachment.  If you would like a copy of it, I'll be happy to make it available
to you.  It is 530 kb.

Comment 2

12 years ago
a stack trace would be appreciated, since java is still responding you should be
able to ask it for a java stack trace. (you can try tools>web development>*java*
console) before you trigger this applet.

if you're using a non mozilla.org package, please contact your vendor's support
pages for information about getting symbols for your gecko. alternatively, if
you could build a gecko using mozilla's current cvs (--enable-debug) and
reproduce the problem, and then get a stack trace, that'd work too.

since you're dealing with threads, i'd like a stack trace for all threads, this
will be fairly long, so please attach the output as a file instead of pasting it
here.

http://www.mozilla.org/unix/debugging-faq.html
(Reporter)

Comment 3

12 years ago
I'm not much of a programmer, so I'm in the process of figuring out how to do
all the things you've requested.  I'll work on it more tomorrow, but I thought I
would add a couple more details.

First off, the java console will probably be useless since firefox dies
completely in Linux.  I don't think the java console would remain open.  But I'm
not sure how to display it since there doesn't seem to be a menu item.  I see a
couple extensions that seem to put it back.  I'll try one tomorrow.  Its in
Windows that java keeps working.  I ran it there and got the following messages.
 I don't think its anything very informative though.  no critical errors.

MCS v.3.6 initialized
Connected via socket:
Socket[addr=rsa.sma.ncsu.edu/152.1.91.56,port=2000,localport=4786]
ClientInterface::downloadLib: failed - remotedrive.dll was previously downloaded.
java.io.FileNotFoundException: C:\Documents and
Settings\jbebel\IBM\rsa.sma.ncsu.edu\remotedrive.dll (The process cannot access
the file because it is being used by another process)
	at java.io.FileOutputStream.open(Native Method)
	at java.io.FileOutputStream.<init>(Unknown Source)
	at java.io.FileOutputStream.<init>(Unknown Source)
	at com.ibm.asm.remotedisk.ClientInterface.downloadFile(Unknown Source)
	at com.ibm.asm.remotedisk.ClientInterface.downloadLib(Unknown Source)
	at com.ibm.asm.remotedisk.RemoteDisk.init(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Initializing RemoteDisk v2.2
Established connection to rsa.sma.ncsu.edu:1045
Closing socket
Keyboard selected: 0
Command KVM Server to start sending images
Stopping applet


However, after running an official firefox build, I did get a more informative
message when it died:

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0x00004d22, pid=16718, tid=2983693232
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_04-b05 mixed mode, sharing)
# Problematic frame:
# C  0x00004d22
#
# An error report file with more information is saved as hs_err_pid16718.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success


Maybe that will help some.  I don't get this error in Windows though, with the
same versions of firefox and the jre.

I'll do my best to figure out how to get firefox compiled with debugging sumbols
and create a stack trace tomorrow.  I must go home for now.
(Reporter)

Comment 4

12 years ago
Well, I'm not getting very far.  Red Hat doesn't seem to have a version with
debugging symbols available.  I tried compiling from firefox and configure
complained about not finding libIDL even though the libIDL-devel rpm is
installed.  I tried configuring it with --without-libIDL and it still fails when
I compile it with errors related to libIDL.  So I figured out I needed to make a
symlink from libIDL-config-2 to libIDL-config.  But now I still get a compile
error sayingtoolkit/locales/un-US/chrome/necko/contents.rdf doesn't exist.  And
it doesn't.  Anyway, this has taken too much time trying to figure out just how
to compile firefox with debugging symbols.  Unless someone can help me get it
compiled, or provide me with a pre-compiled debugging version, I can't put more
time into it.

However, I'd be very happy to provide temporary access to the problematic site
to someone who has a version pre-compiled for debugging.  I'd be interested in
knowing the problem isn't just my version anyway.

Comment 5

12 years ago
my guess is bug 298022 comment 2

Comment 6

12 years ago
eep. wrong bug. if you can visit irc.mozilla.org someone can help you.

Comment 7

9 years ago
jbebel

do you still see this?  I've used FF3 with RSA-II in the last few months with no problem
Keywords: crash
Whiteboard: closeme 2008-12-10
(Reporter)

Comment 8

9 years ago
At first I was going to just say I don't have access to that rsa-II card anymore since I don't have that job.  But it turns out they never changed my password on it.  So it turns out, I'm not seeing this anymore either.  Feel free to close it as it seems to be obsolete.

Comment 9

9 years ago
Thanks :)
=> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.