Closed Bug 302260 Opened 19 years ago Closed 16 years ago

ASSERTION: update-band called late: 'psd->mX == psd->mLeftEdge'

Categories

(Core :: Layout: Block and Inline, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bc, Unassigned)

References

()

Details

(Keywords: assertion, top100)

Attachments

(1 file, 1 obsolete file)

I just recently began seeing the following assertion on the branch _and_ trunk
on www.aol.com. They have recently redesigned their homepage, so the appearance
of the assertion may just be due to changed content and not to changes in the
browser.

ASSERTION: update-band called late: 'psd->mX == psd->mLeftEdge', file
c:/work/mozilla/builds/ff/trunk-test/mozilla/layout/generic/nsLineLayout.cpp,
line 387
Attached file testcase (obsolete) —
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 319280
Keywords: assertion
Attached file More minimal testcase
The lack of whitespace before the <span> is key here -- it needs to be the first thing in its block.

When the assert fires, mLeftEdge == 0 and mX is equal to the text-indent value...

I'm not really sure what the right fix would be here, if nothing else because I'm not sure what mX and mLeftEdge are (that is, how they differ).  Some docs in the PerSpanData struct definition would be nice.  ;)
Attachment #190644 - Attachment is obsolete: true
No longer blocks: 319280
Still happens on trunk.
This assertion was removed in the following changeset:

changeset:   15299:5c30c5953d22
user:        Robert O'Callahan <robert@ocallahan.org>
date:        Wed Jun 11 11:53:22 2008 +1200
summary:     Allow floats to be placed on the current line even after nonzero-width inline content has been placed. Fixes an Acid3 layout bug. r+sr=dbaron

The testcase doesn't trigger any other assertions, so I added it as a crashtest.
Status: NEW → RESOLVED
Closed: 16 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: