if I select print preview mozilla,firefox crashed

RESOLVED WORKSFORME

Status

()

Core
Print Preview
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Daniel Smolik, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.2) Gecko/20040803

14051 access("/usr/lib/mozilla/chrome/en-US.jar", F_OK) = 0
14051 open("/usr/lib/mozilla/chrome/en-US.jar", O_RDONLY|O_LARGEFILE) = 42
14051 lseek(42, 27742, SEEK_SET)        = 27742
14051 read(42, "PK\3\4\n\0\0\0\0\0T7T0\246\304\276\264\361\27\0\0\361\27"...,
30) = 30
14051 lseek(42, 27832, SEEK_SET)        = 27832
14051 read(42, "# The contents of this file are "..., 6129) = 6129
14051 close(42)                         = 0
14051 gettimeofday({1122443078, 757212}, NULL) = 0
14051 futex(0x833df74, FUTEX_WAKE, 1)   = 1
14072 <... futex resumed> )             = 0
14072 gettimeofday({1122443078, 953000}, NULL) = 0
14072 gettimeofday({1122443078, 953156}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443078, 953435000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 968, {0, 119721000} <unfinished ...>
14051 open("serif", O_RDONLY)           = -1 ENOENT (No such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 brk(0)                            = 0x899a000
14051 brk(0x89bc000)                    = 0x89bc000
14072 <... futex resumed> )             = -1 ETIMEDOUT (Connection timed out)
14072 gettimeofday({1122443079, 74509}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 gettimeofday({1122443079, 74885}, NULL) = 0
14072 gettimeofday({1122443079, 75150}, NULL) = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443079, 75289000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 969, {0, 509861000} <unfinished ...>
14051 time([1122443079])                = 1122443079
14051 time(NULL)                        = 1122443079
14051 write(3, "\1\20\r\0T\v \2\314\0 \2\0\0\0\0\1\0\1\0\0\0\1\0!\0\0\0"...,
2024) = 2024
14051 open("serif", O_RDONLY)           = -1 ENOENT (No such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 brk(0)                            = 0x89bc000
14051 brk(0x89dd000)                    = 0x89dd000
14051 brk(0)                            = 0x89dd000
14051 brk(0)                            = 0x89dd000
14051 brk(0x89dc000)                    = 0x89dc000
14051 brk(0)                            = 0x89dc000                            
                        
14072 <... futex resumed> )             = -1 ETIMEDOUT (Connection timed out)
14072 gettimeofday({1122443079, 586418}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 gettimeofday({1122443079, 586762}, NULL) = 0
14072 gettimeofday({1122443079, 586900}, NULL) = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443079, 587028000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 970, {0, 437872000} <unfinished ...>
14051 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
14051 unlink("/home/marvin/.mozilla/default/w4koh7s5.slt/lock") = 0


Reproducible: Always

Steps to Reproduce:
1.go to http://www.sectron.cz/index.php?co=produkty&ref=1&sec=3
2.do print prewiev
3.crash

Actual Results:  
crash

Expected Results:  
display preview

14051 access("/usr/lib/mozilla/chrome/en-US.jar", F_OK) = 0
14051 open("/usr/lib/mozilla/chrome/en-US.jar", O_RDONLY|O_LARGEFILE) = 42
14051 lseek(42, 27742, SEEK_SET)        = 27742
14051 read(42, "PK\3\4\n\0\0\0\0\0T7T0\246\304\276\264\361\27\0\0\361\27"...,
30) = 30
14051 lseek(42, 27832, SEEK_SET)        = 27832
14051 read(42, "# The contents of this file are "..., 6129) = 6129
14051 close(42)                         = 0
14051 gettimeofday({1122443078, 757212}, NULL) = 0
14051 futex(0x833df74, FUTEX_WAKE, 1)   = 1
14072 <... futex resumed> )             = 0
14072 gettimeofday({1122443078, 953000}, NULL) = 0
14072 gettimeofday({1122443078, 953156}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443078, 953435000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 968, {0, 119721000} <unfinished ...>
14051 open("serif", O_RDONLY)           = -1 ENOENT (No such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 brk(0)                            = 0x899a000
14051 brk(0x89bc000)                    = 0x89bc000
14072 <... futex resumed> )             = -1 ETIMEDOUT (Connection timed out)
14072 gettimeofday({1122443079, 74509}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 gettimeofday({1122443079, 74885}, NULL) = 0
14072 gettimeofday({1122443079, 75150}, NULL) = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443079, 75289000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 969, {0, 509861000} <unfinished ...>
14051 time([1122443079])                = 1122443079
14051 time(NULL)                        = 1122443079
14051 write(3, "\1\20\r\0T\v \2\314\0 \2\0\0\0\0\1\0\1\0\0\0\1\0!\0\0\0"...,
2024) = 2024
14051 open("serif", O_RDONLY)           = -1 ENOENT (No such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 open("Verdana,Arial,Helvetica,sans-serif,serif", O_RDONLY) = -1 ENOENT (No
such file or directory)
14051 brk(0)                            = 0x89bc000
14051 brk(0x89dd000)                    = 0x89dd000
14051 brk(0)                            = 0x89dd000
14051 brk(0)                            = 0x89dd000
14051 brk(0x89dc000)                    = 0x89dc000
14051 brk(0)                            = 0x89dc000                            
                        
14072 <... futex resumed> )             = -1 ETIMEDOUT (Connection timed out)
14072 gettimeofday({1122443079, 586418}, NULL) = 0
14072 futex(0x833e098, FUTEX_WAKE, 1)   = 0
14072 gettimeofday({1122443079, 586762}, NULL) = 0
14072 gettimeofday({1122443079, 586900}, NULL) = 0
14072 clock_gettime(CLOCK_REALTIME, {1122443079, 587028000}) = 0
14072 futex(0x833df74, FUTEX_WAIT, 970, {0, 437872000} <unfinished ...>
14051 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
14051 unlink("/home/marvin/.mozilla/default/w4koh7s5.slt/lock") = 0

Comment 1

13 years ago
never post an strace unless someone explicitly requests one. mozilla crashes
need *stack* traces, which can be retrieved from core files using gdb. or you
can use a talkback enabled build, crash, run components/talkback and report the
incident id, for which we can retrieve a stack trace. please crash again and
provide one of these items.

Comment 2

13 years ago
I can't reproduce the crash. Could you test the latest nightlies. Mozilla 1.7.2
is almost a year old.
Backup your profile and try a build from
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ and
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/
for firefox and
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/ and
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
for mozilla
to see whether this bug has been fixed already.
Thanks a lot.

Comment 3

13 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050727 SeaMonkey/1.0a
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

1st page shows header only, 
2nd page shows some products, centered as there is a menu to the left and ads to
the right.
3rd page lacks the menu, so the product is printed to the left.
(Reporter)

Comment 4

13 years ago
(In reply to comment #2)
> I can't reproduce the crash. Could you test the latest nightlies. Mozilla 1.7.2
> is almost a year old.
> Backup your profile and try a build from
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ and
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/
> for firefox and
> ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/ and
> ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
> for mozilla
> to see whether this bug has been fixed already.
> Thanks a lot.
On my Woody I cannot run firefox only mozilla , because I missing apropriate
version of libgtk.But this build of   Mozilla  works perfectly. Bug was solved.
Many thanks.
           Dan 

(Reporter)

Comment 5

13 years ago
(In reply to comment #2)
> I can't reproduce the crash. Could you test the latest nightlies. Mozilla 1.7.2
> is almost a year old.
Don't worry I test it with 1.7.10 and problem was the same.

(Reporter)

Comment 6

13 years ago
I do aditional testing:
Mozilla latest-trunk - bug solved
Mozilla 1.7.11 preview - crash
Firefox 1.0.6 latest-aviary1.0.1 - crash this is a code of bug from talk back
agent TB7855068Y

Updated

13 years ago
Keywords: crash
Summary: if I select print prewiev mozilla,firefox crashed → if I select print preview mozilla,firefox crashed
Version: unspecified → 1.7 Branch

Comment 7

13 years ago
Thanks for testing. Moving to Core/Print Preview as this affects both mozilla
and firefox.
Component: General → Print Preview
Product: Mozilla Application Suite → Core

Comment 8

13 years ago
Confirming based on TB and reassigning to compoment owner.
Assignee: general → printing
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: talkbackid
QA Contact: general
(Reporter)

Comment 9

13 years ago
New expirience. Only latest build mozilla without XFT works. All other crash.

Comment 10

13 years ago
Incident ID: 7855068
Stack Signature	nsBlockFrame::DoRemoveFrame() c64ea678
Product ID	Firefox10
Build ID	2005072707
Trigger Time	2005-07-27 09:36:24.0
Platform	LinuxIntel
Operating System	Linux 2.6.11
Module	firefox-bin + (003d0108)
URL visited	http://www.sectron.cz/index.php?co=produkty&ref=1&sec=3
User Comments	
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.
/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 683
Stack Trace 	
nsBlockFrame::DoRemoveFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 683]
nsBlockFrame::DeleteNextInFlowChild() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 4928]
nsBlockFrame::ReflowFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 642]
nsBlockReflowState::FlowAndPlaceFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 57]
nsBlockReflowState::AddFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 65]
nsLineLayout::ReflowFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 235]
nsBlockFrame::ReflowInlineFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3586]
nsBlockFrame::DoReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3446]
nsBlockFrame::DoReflowInlineFramesAuto() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3347]
nsBlockFrame::ReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3288]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2456]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5038]
nsBlockReflowState::FlowAndPlaceFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 57]
nsBlockReflowState::AddFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 65]
nsLineLayout::ReflowFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 235]
nsBlockFrame::ReflowInlineFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3586]
nsBlockFrame::DoReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3446]
nsBlockFrame::DoReflowInlineFramesAuto() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3347]
nsBlockFrame::ReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3288]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2456]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5038]
nsBlockReflowState::FlowAndPlaceFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 57]
nsBlockReflowState::AddFloat() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 65]
nsLineLayout::ReflowFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 235]
nsBlockFrame::ReflowInlineFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3586]
nsBlockFrame::DoReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3446]
nsBlockFrame::DoReflowInlineFramesAuto() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3347]
nsBlockFrame::ReflowInlineFrames() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3288]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2456]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsPageContentFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPageContentFrame.cpp,
line 51]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsPageFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPageFrame.cpp,
line 214]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsSimplePageSequenceFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsSimplePageSequence.cpp,
line 55]
nsBoxToBlockAdaptor::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 628]
nsBox::Layout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsScrollBoxFrame::DoLayout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsScrollBoxFrame.cpp,
line 337]
nsBox::Layout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::LayoutChildAt() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 654]
nsGfxScrollFrameInner::Layout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1421]
nsGfxScrollFrame::DoLayout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1272]
nsBox::Layout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsBoxFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 869]
nsGfxScrollFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 870]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 252]
PresShell::InitialReflow() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 658]
nsPrintEngine::ReflowPrintObject() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2796]
nsPrintEngine::ReflowDocList() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2553]
nsPrintEngine::SetupToPrintContent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2409]
nsPrintEngine::DocumentReadyForPrinting() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2178]
nsPrintEngine::FinishPrintPreview() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 4474]
nsPrintEngine::PrintPreview() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 1258]
DocumentViewerImpl::PrintPreview() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 3253]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2033]
XPC_WN_CallMethod() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1781]
js_Invoke() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 955]
js_Interpret() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 2999]
js_Invoke() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 972]
js_InternalInvoke() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1050]
JS_CallFunctionValue() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3698]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1296]
GlobalWindowImpl::RunTimeout() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 710]
GlobalWindowImpl::TimerCallback() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 5843]
nsTimerImpl::Fire() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 383]
handleTimerEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 450]
PL_HandleEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 402]

if you can crash w/ a trunk build, that'd be appreciated, if we don't have any
builds that fit the requiremenets and you can build --enable-debug and crash
that, that'd be even better (if you do, please visit irc.mozilla.org and someone
should arrange for life analysis).

possibly bug 266360
(Reporter)

Comment 11

13 years ago
> if you can crash w/ a trunk build, that'd be appreciated, if we don't have any
> builds that fit the requiremenets and you can build --enable-debug and crash
> that, that'd be even better (if you do, please visit irc.mozilla.org and someone
> should arrange for life analysis).

I have no expirience with compilng mozilla. But I can try this. I someone have
mozilla with debug enabled I can test it. Need  you this action to solve this bug ?
Dan

Comment 12

13 years ago
> New expirience. Only latest build mozilla without XFT works. All other crash.

Are you saying latest trunk SeaMonkey gtk1 builds crash?
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/

worksforme with linux seamonkey trunk 2005072805
(Reporter)

Comment 13

13 years ago
(In reply to comment #12)
> > New expirience. Only latest build mozilla without XFT works. All other crash.
> 
> Are you saying latest trunk SeaMonkey gtk1 builds crash?
> http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
> 
> worksforme with linux seamonkey trunk 2005072805
I test this version on my notebook on Debian Sarge an works OK.
This version  ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
works OK on may old woody box. This firefox
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/
crashed as I described later.
Dan

Comment 14

12 years ago
Daniel, according to your last comment this bug has been fixed in the latest
builds. Resolving as WORKSFORME. Feel free to reopen this if you can reproduce
in the latest trunk builds.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: talkbackid
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

12 years ago
(In reply to comment #14)
> Daniel, according to your last comment this bug has been fixed in the latest
> builds. Resolving as WORKSFORME. Feel free to reopen this if you can reproduce
> in the latest trunk builds.

Can I test this build
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8-l10n/ ?
Is it what do you mean ?
Dan

Comment 16

12 years ago
Daniel, anything in latest-mozilla1.8/ or latest-trunk/ should be fine.
(Reporter)

Comment 17

12 years ago
It is now OK. I test latest firefox on my Sarge and works. Thanks.

Dan
You need to log in before you can comment on or make changes to this bug.