Bad file type assumed, wrong application started

VERIFIED DUPLICATE of bug 160755

Status

()

VERIFIED DUPLICATE of bug 160755
13 years ago
10 years ago

People

(Reporter: herter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Try to download the 2nd from the top paper by Dey, Edelsbrunner, 
and Guha.  The link of this paper is: 

  http://www.ics.uci.edu/~eppstein/gina/DeyEdelsbrunnerGuha.ps.Z

Its a compressed postcript, and yet Firefox "thinks" that this is 
a postscript file and it starts my Ghostscript with the file
DeyEdelsbrunnerGuha.ps.Z.ps as its argument. The html source code is:
  [...
  <LI><A HREF="DeyEdelsbrunnerGuha.ps.Z">Computational Topology</A>.
  Survey paper by Dey, Edelsbrunner, and Guha,...
  ...]
Looks prety standard to me.

This file appears in the Download Manager window, but even there
I have only "open" link, which does the same mess and starts 
Ghostscript on the compressed file. I finally changed the action 
for *.ps file to "save to disk" to succede with the download.

(By the way:  To this day I failed to discover how to force Firefox 
to download a file from a link by omitting the handling application,
with Netscape/Mozilla this the Shift-Click combination, Firefox 
does something else than for reason unknown to Mankind...)


Reproducible: Always

Steps to Reproduce:
1.Click on the link!
2.
3.



Expected Results:  
Correctly act after the *.Z suffix, not after the *.ps 
suffix of the file.

Comment 2

13 years ago
Related to/duplicate of Core bug 160755?

Comment 3

13 years ago
(In reply to comment #0)
> (By the way:  To this day I failed to discover how to force Firefox 
> to download a file from a link by omitting the handling application,
> with Netscape/Mozilla this the Shift-Click combination, Firefox 
> does something else than for reason unknown to Mankind...)

Alt+Click seems to work, see bug 255181 and bug 213816 comment 12.

*** This bug has been marked as a duplicate of 160755 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.