In a fixed-width select, the small options are not as wide as the select if a wide option is available

VERIFIED FIXED

Status

()

VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: acm, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

In Deer Park Alpha 2, the code below renders two select-boxes each 70px wide.
When you open the first one, hovering besides the word 'foo' or 'bar' works as
expected, the entire width of the opened select-box is highlighted.

When the second is opened and you hover over 'foo'-option only the word 'foo' is
highlighted, not the white space besides it.

<head>
 <style>
    select {
		width : 70px;
	}
 </style>
</head>
<body>
<select>
	<option>foo</option>
	<option>bar</option>
</select>
<select>
	<option>foo</option>
	<option>bar bar bar bar bar bar bar bar</option>
</select>
</body>

Reproducible: Always
Created attachment 190872 [details]
testcase comment 0

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050728
Firefox/1.0+ ID:2005072812

Confirmed

Comment 2

13 years ago
WFM with Mozilla 1.8b1 but reproducible with SeaMonkey/20050727. The white space
next to 'foo' becomes highlighted again when I change width: to 192px (or more),
so maybe a regression of Core bug 190265 -> Core bug 108127?
Status: UNCONFIRMED → NEW
Ever confirmed: true
No idea whether this is wrong or right, but I do know there's absolutely no
point in confirming a layout bug in Firefox's Form Manager component, because no
layout people will ever see it, and now that it's confirmed they probably won't
see it even after it's moved :(
Component: Form Manager → Layout: Form Controls
Product: Firefox → Core
QA Contact: form.manager → layout.form-controls
Version: unspecified → Trunk
This is a duplicate in any case, I'm pretty sure.
Whiteboard: DUPEME

Comment 5

13 years ago
I can confirm this bug. It's annoying. Go to http://demo.control-online.net
click on the button "Nicht Anmelden". Afterwards, there are 4 select boxes - all
of them  have a fixed css width. The whitespace next to the option text isn't
hovered and you can only select an option if the mouse is above the option text.

This problem did NOT occur with FireFox 1.0.6. Also, this problem does NOT
always occur. Sometimes, select boxes with a fixed width are display properly,
although that doesn't happen very often.

Thanks in advance for fixing this annoying bug!
Fixed by checkin for bug 305705
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED using testcase https://bugzilla.mozilla.org/attachment.cgi?id=190872&action=view on build 2005-11-15-08 of SeaMonkey trunk on Windows XP.
Status: RESOLVED → VERIFIED
*** Bug 320940 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.