Going back in the history to CGI scripts doesn't work properly

VERIFIED DUPLICATE of bug 1718

Status

()

P3
major
VERIFIED DUPLICATE of bug 1718
19 years ago
10 years ago

People

(Reporter: james, Assigned: radha)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I'm working on an internal software application that uses CGI scripts for
everything.  When using M14 and going backwards or forwards in the history, the
previous screens form values are not being submitted again, which causes my
scripts to generate the correct error messages for when someone goes to them
without specifying the needed data.  This also happens when I try to view source
on a page.

We currently do not have a demo available that you can access, but are planning
on going public with the application in the near future.   If this bug is not
resolved before then, we will update it and provide a link to our demo for you
to test against.

Comment 1

19 years ago
I have a test page at http://www.vortxweb.net/ccs-pg/my-cgi/toykar/chayka5.cgi
that is having the same problem. There are 4 cgi scripts total, submitting from
one page initiates the next one. In addition, the external style sheets are
ignored on all but the first page (I think this is already logged as another bug).

Comment 2

19 years ago
This sounds reminiscent of bug 27513, "back button fails after bad login"

Comment 3

19 years ago
this is definetly a dupe of something, there was a bug about submitting forms(or a POST operation) and going back. cc'ing 
petersen who might remembe such a bug
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

*** This bug has been marked as a duplicate of 1718 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.