Add checkbox (and edit field) to create new folder to feed properties when subscribing.

RESOLVED INVALID

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED INVALID
13 years ago
4 years ago

People

(Reporter: Pontus Freyhult, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050728 Thunderbird/1.0+

Currently, there's a certain amount of DWIM when subscribing to feeds that may
be confusing for users:

If the account root is selected, a new folder will be created with the name of
the feed. This folder is then used to store the feed.

If any folder other than the account root is selected, the feed is stored
directly in that folder.

I think this can be confusing and should be replaced. What I propose instead is
to add a checkbox and an edit field to the properties box when adding feeds, in
addition to the current folder selector

The checkbox should be used to choose whatever to create a new folder to store
the feeds in and the edit field should be the name of the new folder, if
creation is desired.

Reproducible: Always

Steps to Reproduce:
QA Contact: rss

Comment 1

10 years ago
See also: Bug 325107 – subscribing to rss feeds should create a new folder by default
https://bugzilla.mozilla.org/show_bug.cgi?id=325107

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Updated

6 years ago
Duplicate of this bug: 325107

Updated

6 years ago
Duplicate of this bug: 350500
Summary: RFE: Add checkbox (and edit field) to create new folder to feed properties when subscribing. → Add checkbox (and edit field) to create new folder to feed properties when subscribing.

Comment 4

4 years ago
The old extra popup dialog for adding feeds no longer exists, so this in invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.