Random crashing while reloading pages within 15 seconds [@ MarkGCThing]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Nick Laquidara, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+

When using an autosurfer such as http://autohits.info the page randomly crashes
when the page reloads. May be related to the frames.

Reproducible: Sometimes

Steps to Reproduce:
1. Load up deer park alpha 2
2. browse to http://www.autohits.info./view.php?user=test and minimize the window
3. wait several seconds to several minutes for the browser to crash.

Actual Results:  
Browser crashes and talkbalk loads

Expected Results:  
Should have loaded without crashing.

No themes/extensions, fresh profile. Tried deleting the mozilla firefox folder
and then copy the new build into it.
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
WFM. No crash. But it managed somehow to maximize itself when minimized :?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> WFM. No crash. But it managed somehow to maximize itself when minimized :?

Yeah, I also have that problem. It's annoying when you're typing something and
it pops up. I sometimes lose an entire sentence like that.
Please file a talkback report and post the ID here.
(Reporter)

Comment 4

13 years ago
Here's the last one I got. it's dated a few hours ago.

Talkback ID: TB7920587Y
There are a few bugs listed as crashing here, I couldn't say whether this was a
dupe of those or not though.
Component: General → JavaScript Engine
Product: Firefox → Core
Summary: Random crashing while reloading pages within 15 seconds → Random crashing while reloading pages within 15 seconds [@ MarkGCThing]

Comment 6

13 years ago
(In reply to comment #0)

> When using an autosurfer such as http://autohits.info the page randomly crashes
> when the page reloads. May be related to the frames.

I assume it is related to the contents of the frames. Had it running for a while
in Seamonkey, and found a nice collection of errors in JS console.
Things denied because of security, like someone trying to access the local
dreamweaver installation. Don´t know if deliberately or by error, I don´t have
dreamweaver installed. So if an ad contains a crasher bug, Deer Park will crash,
but you don´t have a reproducible testcase, as you don´t know the URL.

Was the page working before you updated Deer Park, or did you find the page, and
it was crashing randomly?

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
Closed as FIXED, even though no code was checked in and the last comment
indicates that the original problem isn't reproducible.

Apparently, nothing was actually broken or fixed.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
It never crashed for me at all when I tried it in FF1.0.6.
It was only when I tried to Deer Park Alphas that it started crashing. Also, I
remember that when I was using Deer Park Alpha 1 there was no crash at. So,
sometime between the release of DP A2 and yesterday some sort of problem occured.

Comment 9

13 years ago
(In reply to comment #7)
> Closed as FIXED,

I never intended to change the status of this bug, don't know how it happened
when I sent comment 6

Re comment 8:
Nick, so it seems Deerpark Alpha 2 got a new crasher bug somewhere.
But it also can be that just a new ad crashing Firefox came after you installed
Deer Park.
While I'm using Seamonkey, it is running now for some minutes on 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+

(Reporter)

Comment 10

13 years ago
(In reply to comment #9)
> (In reply to comment #7)
> > Closed as FIXED,
> 
> I never intended to change the status of this bug, don't know how it happened
> when I sent comment 6
> 
> Re comment 8:
> Nick, so it seems Deerpark Alpha 2 got a new crasher bug somewhere.
> But it also can be that just a new ad crashing Firefox came after you installed
> Deer Park.
> While I'm using Seamonkey, it is running now for some minutes on 
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+
> 
> 
I think I may have an idea why it's not crashing. Maybe the sites on the test
account are different than the ones that are being displayed on my account. it
could be one of the sites that cause it to crash. Try using the url
http://autohits.info/view.php?user=kuragari for a few minutes and see if it's
any different than the test account.
You need to log in before you can comment on or make changes to this bug.