Closed Bug 302667 Opened 17 years ago Closed 17 years ago

Unfocused tabs cannot be reordered with a single click

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: peterhewitt, Assigned: aaronlev)

References

Details

(Keywords: regression, Whiteboard: [in-litmus-bug-week])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+

Bug #297421 fixed the annoying problem of the focus rect appearing on newly
opened tabs and clicked tabs. However this did ally you to simply grab and drop
a tab to reorder it.

Now to reorder a tab you must click to open it and then reorder it. This is
harder and less discoverable.

Reproducible: Always

Steps to Reproduce:
1. Click and hold another (not-current) tab and drag
2. Nothing occurs
3. Click again and drag and it will reorder

Actual Results:  
Tabs do not reorder on first click

Expected Results:  
Allow single click and drag reordering
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050728
Firefox/1.0+ ID:2005072806

Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8b4?
Keywords: regression
perhaps tab switches should occur on mousedown, but the focus should only be
able to change on mouseclick
Severity: normal → major
Aaron, we need help on this one. Can you? Mike, what about you? I think this is
definitely a blocker to our tab drag and drop story.
Flags: blocking1.8b4? → blocking1.8b4+
I just backed out the fix from bug 297421 locally and I don't see this problem
going away.  Something else is eating this it seems.  Taking to investigate.
Assignee: nobody → mconnor
Summary: Since 297421 tabs cannot be reordered with a single click → tabs cannot be reordered with a single click
Summary: tabs cannot be reordered with a single click → Unfocused tabs cannot be reordered with a single click
ok, so my build was horked, we could regress that bug for tabbrowser only, or
make tabbrowser work onclick instead of onmousedown... I don't like those
options, but focus is a pain.
(In reply to comment #5)
> ok, so my build was horked, we could regress that bug for tabbrowser only, or
> make tabbrowser work onclick instead of onmousedown... I don't like those
> options, but focus is a pain.

Mike, what do you think about my idea in comment 2.
Actually I think I have it wrong im comment 2.

It seems like the drag and drop code requires that the dragged tab be focused.
Is there a good reason for that?
In fact I debugged more and found that the ondrag* DOM events don't get fired at
all unless the tab has focus.
Attachment #191218 - Flags: review?
Attachment #191218 - Flags: review+
Attachment #191218 - Flags: approval1.8b4+
Checking in toolkit/content/widgets/tabbox.xml;
/cvsroot/mozilla/toolkit/content/widgets/tabbox.xml,v  <--  tabbox.xml
new revision: 1.28; previous revision: 1.27
done
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Litmus Test Case Updated:
https://litmus.mozilla.org/show_test.cgi?id=10006
Flags: in-litmus+
Whiteboard: [in-litmus-bug-week]
Depends on: 752918
No longer depends on: 752918
You need to log in before you can comment on or make changes to this bug.