Firefox crashes during nightly build update

RESOLVED INCOMPLETE

Status

()

Toolkit
Application Update
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: AvvY, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050729 Firefox/1.0+

Using DP a2. Enabled the update service. I now use check for updates menu to
update. Each time - the past 4 days - it downloads the update, says it is
applying it, then when firefox needs to restart it crashes. in some cases i need
to end process in the task manager.

Reproducible: Always

Steps to Reproduce:
1. Download and install dpa2
2. Run "check for updates"
3. Download and apply updates
4. Let Firefox restart
Actual Results:  
Firefox crashes and needs to be manual started again - sometimes requires an end
process in task manager.

Expected Results:  
Firefox should apply the updates, close and restart.
Can you provide a talkback ID for the crash please:
http://kb.mozillazine.org/Talkback

Is it firefox that crashes or the "applying updates" process that crashes?

Comment 2

13 years ago
Can you please test updating from the 7/29 build to the 7/30 build when it comes
out tomorrow?  If the problem does not occur, then I suspect that this bug is
probably a duplicate of bug 300404.  (When debugging that bug, I found that the
updater.exe did in fact crash on me.)
(Reporter)

Comment 3

13 years ago
I believe it is firefox which crashes. It fully aplys the update, then closes to
restart, then crashes. I looked at the crash info in winxp and it said
firefox.exe. Unlike bug #300404 this happens when you choose to restart immediately.

I will give a full report on upgrading to the next build.

Late,
(Reporter)

Comment 4

13 years ago
Ok, I just updated from:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050729
to
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050730
and recieved the same problem. I have attached a screenshot of the error
dialogue which Windows spurts up to do an error report.

I will reinstall DP a2 and enable Talkback, then run another update to the
latest build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050730 
and see what that has to say.

Late,

(Reporter)

Comment 5

13 years ago
Created attachment 191078 [details]
Firefox error report dialogue
(Reporter)

Comment 6

13 years ago
I had tried testing with the talkback agent on, but it doesn't detect an
incident. I tried having it open while i ran the update, but that resulted in
firefox "applying updates" but infact it didn't update -
I was trying thos going from installing the 29/7 build to the 30/7 build.

Late,

Comment 7

13 years ago
Does firefox crash when you launch it again after a crash?  Do you have any
funny extensions installed?  Can you try reproducing this crash problem with a
fresh firefox profile?
(Reporter)

Comment 8

13 years ago
Firefox runs fine after manually restarting. I have the following extensions
installed - all AFAIK are 1+ compadible:
Flashgot
Adblock
ForecastFox
TabBrowser Prefs
NewUsage Item
CuteMenus2

I will try this with a fresh profile though and report back results later.

Comment 9

13 years ago
Reporter? Is this bug still a problem for you?

Comment 10

13 years ago
I also get this crash - updating to 20050919 today caused this problem. I
retried the update (uninstalled, installed yesterdays nightly, updated)
and managed to get a Windows error dialog like:

	XPCOM:EventReceiver: firefox.exe - Application Error

	The instruction at "0x00531A9D" referenced memory at
	"0x00000000". The memory could not be "read".

I also tried with a clean profile (only changed the proxy settings) and the
update succeeded.

I tried removing Adblock (the only extension the original reporter and I had
in common), but it still crashed with my normal profile. 

I shall keep prodding at it when I have some more time available.

Other Info: Windows XP SP2.

I have these extensions:
- Adblock 0.5.2.039
- Mouse Gestures 1.0.1
- OpenBook 1.3.4
- Paste and Go 0.4.2
- Plain Text Links 0.2
- Sage 1.3.5
- Update Bookmark 0.0.4
- View Rendered Source 1.0.01
- Greasemonkey 0.6.1.1
- Platypus 0.51
- Nightly Tester Tools 0.7.9.2

From memory, not all these are 1.4/1.5 compatible.

Comment 11

13 years ago
Hmm, when adding that last comment, I somehow got redirected over to bug
305296 (which confused me no end!).

Reading the comments there I found I had app.update.showInstalledUI set to true.
I set it to false and updated again. This time no crash.

Comment 12

13 years ago
I've seen this with Firefox for a while: after the update was applied, I got a
windows error report dialog. Manually starting Firefox works fine afterwards.
I somehow fixed this by reinstalling Firefox into a clean directory.

The problem is that I encounter this in Thunderbird as well and haven't managed
to find a workaround.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Anyone still seeing this?

Comment 14

13 years ago
(In reply to comment #13)
> Anyone still seeing this?
> 

I just tried to reproduce, and it didn't crash. This was a nightly
update from 2005121903 to 2005122003 so not a particularly interesting
update.

Seems like it may be fixed to me.

Comment 15

13 years ago
Same here: I run FF (DeerPark Alpha 20060205 from the directory here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ and it still has the problem in Tools->Check for Updates that 'Resume Downloading DeerPark 1.6alpha and 'Connect to Server' takes forever...

In Tools->Options->Advanced->Update->Show Update History, I see a failed update patch for 2006011305 update patch file....

Q: How to fix???

 I need to D/L updates from Mozilla server shown herein. to apply updates which defeats the purpose. 

Other than this DeerPark works NICELY. 

A: Might I need to get the 2006013105 patch and put it into my folder of
C:\Program Files\Mozilla Firefox\updates?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Resolving -> incomplete due to no reply from the reporter to comment #9.

Reporter, if you are still experiencing this bug please either file a new bug or reopen this bug.

If you are not the reporter and are experiencing this bug please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.