usevisibilitygroups turned on shouldn't prevent you from looking for users being in no groups

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Accounts
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Frédéric Buclin, Assigned: Joel Peshkin)

Tracking

2.20
Bugzilla 2.20

Details

(Reporter)

Description

13 years ago
There is no way to search for users being in no group, or being in system groups
such as canconfirm and/or editbugs only.

Such users should be visible in all cases. If you want to hide them, add them to
a  group used for bugs.

We already had many bugs about the fact that the admin couldn't see his users.
So it's more annoying than helpful.
I like the idea of having a bz_everybody group which everybody is a member of.
By default, this group would be visible to admin and editusers groups members.

This would allow us to keep the current (working) mechanics, and it would allow
us to treat system groups, other non-bug groups and bug groups equivalently.
(Assignee)

Comment 2

13 years ago
That sounds like the best solution.
(Reporter)

Comment 3

13 years ago
Looks like what I said in comment 0 is wrong about system groups. System groups
are visible if the "Visibility" checkbox is checked for these groups. This left
us with users with no privs.

/me thought system groups were visible by the admin group by default.
(Reporter)

Comment 4

13 years ago
Updating the summary of the bug accordingly.
Summary: usevisibilitygroups turned on shouldn't prevent you from looking for users being in no groups or in system groups only → usevisibilitygroups turned on shouldn't prevent you from looking for users being in no groups
*** Bug 303492 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 307413 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
LpSolit reports that this also prevents users privs from being edited, at all,
if they are new users. So that's a blocker.
Severity: normal → major
Flags: blocking2.20.1+
(Reporter)

Comment 8

12 years ago
When an admin creates a new user account, this account has no privs by default
(well, unless you let .* as the default regexp for some groups, which isn't the
case on b.m.o for instance), but changing privs for this user account returns
the following error:

"Sorry, there are visibility restrictions on certain user groups, and so you are
not authorized to modify the user you specified."

In other words, you cannot edit privs for users being in no group (you have
access to). Workaround: disable usevisibilitygroups! Heh :)
Target Milestone: --- → Bugzilla 2.20

Comment 9

12 years ago
I have tried to disable usevisibilitygroups, and this did not work for me. :(
(Reporter)

Comment 10

12 years ago
Now that bug 303784 is fixed, users with 'editusers' privs can override
visibility restrictions and see all users, even those being in no group. Do we
want something more about editing users? If not, then we should close this bug.

I think that this bug is no longer a blocker. joel?
(Assignee)

Comment 11

12 years ago
correct
(Reporter)

Comment 12

12 years ago
Fixed by bug 303784, so it's not a blocker anymore.
Severity: major → normal
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking2.20.1+
Resolution: --- → FIXED
(Reporter)

Updated

12 years ago
Assignee: user-accounts → bugreport
You need to log in before you can comment on or make changes to this bug.