Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 302727 - allow users to create attachments from comments
: allow users to create attachments from comments
Status: RESOLVED DUPLICATE of bug 130011
Product: Bugzilla
Classification: Server Software
Component: Attachments & Requests (show other bugs)
: 2.18.1
: All All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: default-qa
Depends on: 302684
  Show dependency treegraph
Reported: 2005-07-29 19:47 PDT by Myk Melez [:myk] [@mykmelez]
Modified: 2007-10-03 10:36 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Description Myk Melez [:myk] [@mykmelez] 2005-07-29 19:47:58 PDT
Users should be allowed to specify that a comment entered into the additional
comments textarea should be attached to the bug report as an attachment rather
than a comment.

Not only does this provide a much easier way to submit an attachment via cut and
paste when complex updates like obsoleting older attachments and requesting
review are not required, it also makes it possible to divert large comments into
attachments, for example by automatically checking the box enabling this
functionality when a comment reaches a certain size.

When autodiversion of large comments to attachments is enabled, it should be
very obvious when it is going to take place.  For example, we could display a
warning message next to the Additional Comments textarea and color the
textarea's background light red or some other color.  When autodiversion is
enabled, it should also be possible for the user to cancel it if she decides
that the text really should be a comment.

In order to do this, attachment creation must be refactored into,
which is bug 302726.  Bug 232218 could probably also be dealt with similarly.
Comment 1 Frédéric Buclin 2005-11-16 18:04:04 PST
sounds very similar to bug 130011
Comment 2 timeless 2006-11-26 06:47:42 PST
please make sure that people get *sent* copies of the attachment in bugmail.
Comment 3 Frédéric Buclin 2007-10-03 10:36:00 PDT

*** This bug has been marked as a duplicate of bug 130011 ***

Note You need to log in before you can comment on or make changes to this bug.