won't accept my order; says I need to fill out birthdate even though birthdate is filled in

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: Nitehawk Jarrett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-08-01, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

This site has given me problems since day one. I always have to open VPC and
then use the site to get anything done. When registering at the site I couldn't
input my birthdate because it wouldn't open the "calendar" on the site. Now my
birthdate shows on the order page but it seems like Firefox (and IE for Mac,
Opera, Netscape, and iCab) can't go beyond that because I keep getting a "You
must be 21 years of age to order from us. Please select your birthdate from the
calendar." error. I'm thinking this could just be some bad coding on the sites
part (ie. limiting use to Windows PCs only). If so is there a work around? If
not, I think I have a loooong email to send these people.

Reproducible: Always

Steps to Reproduce:
1. Log in
2. Select order
3. Click check out
4. Click continue on next page (which is the URL I submitted)

Actual Results:  
I can go no further

Expected Results:  
Taken me to a page showing my order and payment options.

Comment 1

9 years ago
do you still see this problem? please update the bug with comment and/or close as appropriate.

(bug has no comment since 2007-01-01)
Whiteboard: closeme 2009-08-01
No reply, INCO. Please reopen if you are seeing this in Firefox 3.5.2 or later in Firefox safe mode and a new profile with the latest plugins.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Profiles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.