Sanitize won't close on its own

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: poorlydrawnplato, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050721 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050721 Firefox/1.0+

This is different than 288900 because even after waiting "a few seconds",
Sanitize won't close. Seems that it works though- hitting Cancel then Sanize
again shows a bunch of greyed out checkboxes.

Reproducible: Sometimes

Steps to Reproduce:
Run Sanitize
Actual Results:  
Sanitized, then closed

Expected Results:  
Sanitized, but gave no indication of having done so, even after a significant
period of time.

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050801 Firefox/1.0+
ID:2005080113

I couldn't reproduce. Possibly extensions are to blame? Do you see this in a
clean profile?

Comment 2

13 years ago
Sanitizer code doesn't catch exceptions like the ones reported in bug #265028,
and this can cause the behaviour described here.
Exception handling is implemented in attachment #192644 [details] [diff] [review] for bug #284086: please
retest after it is fixed.
Depends on: 284086

Comment 3

13 years ago
poorlydrawnplato@gmail.com, is this still an issue in the latest builds?
Version: unspecified → Trunk
no reply from the reporter since over 12 month. Also wfm on Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.1) Gecko/20061010 Firefox/2.0

Reporter, if you can reproduce your reported Bug/Problem with the latest Build, or latest release, feel free to reopen this bug.

Resolving this as WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.