If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Character entity ♦ not appearing under Mac Mozilla

RESOLVED DUPLICATE of bug 212745

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 212745
12 years ago
12 years ago

People

(Reporter: outlawsamurai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716

Affected software includes Mozilla, Firefox, Camino.

♦ character entity does not work under Mozilla, as tested on several Macs
running Mac OS X 10.4.2.  An XHTML DTD was specified in the document. Of note:
It works under Apple's Safari web browser.  Using the example markup below, the
diamond appeared in the title, but did not appear in the body of the page.

Quick example:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html>
<head><title>&diams;</title></head>
<body><p>&diams;</p></body>
</html>

See the following for relevant information:
http://www.w3.org/TR/xhtml1/dtds.html
http://www.w3.org/TR/xhtml1/DTD/xhtml-symbol.ent


Reproducible: Always

Steps to Reproduce:
1. Use &diams; appropriately in a document on a Mac running Mozilla
2. View that document in Mozilla
Actual Results:  
The diamond was displayed in the title but not the body.

Expected Results:  
Display the diamon in the body, as well.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 212745 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.