Body of outgoing message is blank in today's build

VERIFIED FIXED in M14

Status

P3
blocker
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: phil, Assigned: mscott)

Tracking

({regression, smoketest})

Trunk
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using 3/3 morning build on Windows NT

Compose a message, and send it to yourself
Receive the message
No body text is shown
(Reporter)

Comment 1

19 years ago
Tried to read the message in 4.7. No body there either. Data loss. Bad bad bad.

Comment 2

19 years ago
I'm on it like hair on a monkey :-)

- rhp
Status: NEW → ASSIGNED
Target Milestone: M14
(Reporter)

Updated

19 years ago
Keywords: dogfood
I am looking at it too.

Comment 4

19 years ago
Well, the reason that the emails are blank is that:

    rv = conv->ScanHTML(bodyText, whattodo, &wresult);

is returning an empty HTML document in wresult. Looking into what is going on 
inside of ScanHTML().

- rhp
I am seeing this on Mac. Update platform to all.
Keywords: regression
OS: Windows NT → All
Hardware: PC → All

Comment 6

19 years ago
Can this be the same thing were seeing in Aim? Bugsplat bug 
http://scopus/bugsplat/show_bug.cgi?id=386904
(Reporter)

Comment 7

19 years ago
Do you mean a different bug? 386904 seems to be something else. But IM 
conversations are losing a lot of data in today's build too.

Updated

19 years ago
Keywords: smoketest

Comment 8

19 years ago
Probably...if they scan the text for conversion before sending...probably.

- rhp

Comment 9

19 years ago
Update: using builds 2000-03-03 on linux, html only.  Also note, copy to sent 
folder fails sending an html message, but not a plain text message. 

Comment 10

19 years ago
Sorry I meant Aim bug  http://scopus/bugsplat/show_bug.cgi?id=387213
Can't see messages in IM conversation log.

Comment 11

19 years ago
udating my update.  the copy to sent folder of an html message, fails on all 
platforms too, probably related to this.

Comment 12

19 years ago
Ok, well, I think it narrows down to this block of code inside of 
mozTXTToHTMLConv::ScanHTML():

      PRUint32 start = PRUint32(i);
      i = aInString.FindChar('<', PR_FALSE, i);
      if (i == kNotFound)
        i = lengthOfInString;
  
      nsString tempString;     
      tempString.SetCapacity((PRUint32(i) - start) * growthRate);
      UnescapeStr(aInString.GetUnicode(), start, PRUint32(i) - start, 
tempString);
      ScanTXT(tempString.GetUnicode(), tempString.Length(), whattodo, 
aOutString);

When I was walking through this, it looked like tempString was always set to "" 
when I should have seen some body text...I think.

I'll keep digging, but I'd like mscott to take a look at this.

- rhp
(Reporter)

Comment 13

19 years ago
Left sticky note at work and voice mail at home for mscott.

Comment 14

19 years ago
Actually, the copy to sent folder of an HTML message only - failed for linux and 
mac only.  windows was OK.  I thought this was related.  Maybe this isn't 
related, I'll log a separate bug.
(Reporter)

Comment 15

19 years ago
FCC fails for me on NT. I have no idea if that's the same bug as blank body or not.

Comment 16

19 years ago
copy to folder on send failed for me on Win98 too.
(Reporter)

Comment 17

19 years ago
FCC plain text works for me, though (FCC HTML doens't), so it might be the same bug.

Comment 18

19 years ago
Since we're also seeing this IM, I think this may be due to ender not returning 
its content when queried.  Just a hunch.
(Assignee)

Comment 19

19 years ago
I have a fix. There was a bug in one of my changes that really showed itself on
small messages and not larger ones. getting permission to check in now.

Comment 20

19 years ago
Thanks buddy

- rhp
Assignee: rhp → mscott
Status: ASSIGNED → NEW
(Assignee)

Comment 21

19 years ago
I should be thanking you not the other way around. Thanks for the detective work.

Esther, I hear there's another bug about messages not getting copied to the sent
folder. Did you file a separate bug or is that in this one too.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 22

19 years ago
*** Bug 30314 has been marked as a duplicate of this bug. ***

Comment 23

19 years ago
Scott, no I didn't file a  separate bug for the HTML failing in copy to sent 
folder.  I suspected and so did Phil that it was part of the bug.  I just tested 
this fix and the Copy to sent is fixed too.  
Using build 2000-03-03-12 on linux and 2000-03-03-13 on Mac this is fixed. Still 
waiting for Windows build to test.
(Reporter)

Comment 24

19 years ago
Windows build is available and both issues appear to be fixed

Comment 25

19 years ago
using build 2000-03-03-14 on win98 this is fixed. verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.