Fix leak of cairo surface in SVG cairo renderer

RESOLVED DUPLICATE of bug 297977

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 297977
12 years ago
12 years ago

People

(Reporter: tor, Assigned: tor)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.01 KB, patch
roc
: review+
Benjamin Smedberg
: approval1.8b4+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
 
(Assignee)

Comment 1

12 years ago
Created attachment 191109 [details] [diff] [review]
plug leak
Attachment #191109 - Flags: review?(roc)
cairo.h says about cairo_create:
 * This function references @target, so you can immediately
 * call cairo_surface_destroy() on it if you don't need to
 * maintain a separate reference to it.
(Assignee)

Comment 3

12 years ago
Created attachment 191150 [details] [diff] [review]
alternate version
Attachment #191109 - Attachment is obsolete: true
Attachment #191150 - Flags: review?(cbiesinger)
Comment on attachment 191150 [details] [diff] [review]
alternate version

This is the version I had...
Attachment #191150 - Flags: superreview+
Attachment #191150 - Flags: review?(cbiesinger)
Attachment #191150 - Flags: review+
Attachment #191109 - Flags: review?(roc)
(Assignee)

Updated

12 years ago
Attachment #191150 - Flags: approval1.8b4?

Updated

12 years ago
Attachment #191150 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Comment 5

12 years ago
Included in the patch for bug 297997.


*** This bug has been marked as a duplicate of 297997 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 6

12 years ago
Duped to the wrong bug, reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

12 years ago

*** This bug has been marked as a duplicate of 297977 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.