Sunbird crashes with many remote calendars and bigger fonts (Windows)

RESOLVED DUPLICATE of bug 281554

Status

--
critical
RESOLVED DUPLICATE of bug 281554
13 years ago
13 years ago

People

(Reporter: jsommer, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Opera/8.01 (Windows NT 5.1; U; de)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2

Sunbird crashes on startup in the following configuration:
- more than 10 calenders
- remote calenders
- "reload external calendenders on startup" in options is activated
- font size in windows desktop properties is 10 instead of 8 (default) points.

If I reload the calenders manually, after sunbird is started, there's no error. 
Maybe there is an error with the "reload calender gif" which is wrong positioned 
on startup with greater font-size. With font-site 10, the 10th calender creates 
an scroll-bar.

Reproducible: Always

Steps to Reproduce:
1. create 10 or more remote calenders
2. avtivate "reload external calendenders on startup" in options
3. open windows properties and increase font-size from 8 to 10pt (dialog-textes)
4. start Subird-Calender, it would crash on startup and close after few seconds

Actual Results:  
Sunbird crashes on startup

Expected Results:  
Sunbird should start and reload the remote calendars

Comment 1

13 years ago
Juerg,
    I'm pretty sure that this is a duplicate of bug 281554.  Can you please take
a look at that bug and see if you agree?  If so, please resolve this bug as a
duplicate of bug 281554.  Also, if you have time, can you please download a
nightly build of Sunbird and see if the problem still exists there?  Thanks.
(Reporter)

Comment 2

13 years ago
Thanks for your attention to this problem.

Sorry, you're right: it's a duplicate of bug #281554. I searched for terms like 
"font-size" and didn't found this bug.

Please remember my additional information, which isn't reported in bug 281554. 
This problem ONLY occurs with increased font-size in windows-properties; with 
the default font-size 8pt in windows, everything works fine (I habe more then 20 
remote calendars, no problems).

It's not important, if you have any events in the calendars (it crashes with no 
events and also with 3000) or the remote calendar type (it crashes with webdav 
and also with local files [file://]).

With this informations, this problem is reproducable ALWAYS.

About the nightly build: at the moment, the nightly builds aren't usable. With 
the nightly build from yesterday (and some older) it's impossible to create any 
calendar and already created calenders with older versions aren't visible 
(removing the sunbird-user profile don't solve this problem). So I can't test my 
problem with an nightly-build. If there would be an useable nightly build I'll 
test it.

Best regards
Juerg

*** This bug has been marked as a duplicate of 281554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
(In reply to comment #2)
> Please remember my additional information, which isn't reported in bug 281554. 

You can (and probably should) add this as a comment to bug 281554. :-)  From
what I remember, the problem happened as soon as there were more calendars than
could fit in the listbox (a scrollbar appeared).  I'm not sure if that's what
your font-size test was recreating.
 
> About the nightly build: at the moment, the nightly builds aren't usable. With 
> the nightly build from yesterday (and some older) it's impossible to create any 
> calendar and already created calenders with older versions aren't visible 
> (removing the sunbird-user profile don't solve this problem). So I can't test my 
> problem with an nightly-build. If there would be an useable nightly build I'll 
> test it.

Nightly builds SHOULD be usable.  If they're not, that's a serious problem and
we definitely need a bug on it.  There (hopefully) should be some meaningful
data in the javascript console after Sunbird fails to create a calendar.  If it
isn't what's described in bug 301624, please open a new bug with any information
you think might be relevant, including the javascript errors.

(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Nightly builds SHOULD be usable. If they're not, that's a serious problem
> and we definitely need a bug on it.  There (hopefully) should be some
> meaningful data in the javascript console after Sunbird fails to create a
> calendar.  If it isn't what's described in bug 301624, please open a new bug
> with any information you think might be relevant, including the javascript
> errors.

Thanks for your hint. It really was the bug 301624 (German Timezone) which cause 
my error. I now tested the nightly build from yesterday: the problems seems to 
be solved there.

But some of our users aren't able to use an english programm; so I'll use 0.2 
(German) and waiting for the release of 0.3 which would be translated to German.

My additional comments are posted in the other bug report. About your 
information with the scroll-bar: it's true; with font-size 10pt, the 10th 
calendar needs an scrollbar. I also think, that's the problem. But with font-
size 8 (default) I have more then 20 remote-calendars and 20 calenders also 
needs a scrollbar, but that works in spite of it. 
You need to log in before you can comment on or make changes to this bug.