It should be possible to change background colour for Navigator only

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: Fredrik Toftered, Assigned: jag (Peter Annema))

Tracking

({helpwanted, qawanted})

Trunk
helpwanted, qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.11) Gecko/20050728
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.11) Gecko/20050728

I prefer grey backgrond colour like in Communicator. However, If I change it, it
also affects backgrond colour in Mozilla Mail, which is not desireable. Message
compose and message display should still be white.

So I want a possibility to change backgound colour for Navigator and Mozilla
Mail without affecting each other.

Fredrik

Reproducible: Always

Updated

12 years ago
Assignee: general → jag
Component: General → XP Apps
OS: Windows 98 → All
QA Contact: general
Hardware: PC → All
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted, qawanted
No comment since 2½ years.

I wonder whether a user*.css rule might do it, but how? And otherwise, what "should" an interface for changing colours be? "Changing background colour", for the average user, means "using a different theme", doesn't it?

Comment 2

10 years ago
> I wonder whether a user*.css rule might do it, but how? And otherwise, what

userChrome.css with a @document rule to make it specific to navigator, but the Stylish extension would give you better fine grained control.

> "should" an interface for changing colours be? "Changing background colour",
> for the average user, means "using a different theme", doesn't it?

Yes it should be up to the theme.

I vote for WONTFIX. since this is extension/theme fodder.

Comment 3

10 years ago
Add this to your userContent.css:

@-moz-document url(about:blank) {
  html { background-color: lightgray; }
}

I also think this bug should be WONTFIXed. We can't have an GUI item for anything! The bug reporter is able to fix his issue (which doesn't seem to be an issue for many people) with the above lines of CSS.

Comment 4

10 years ago
The messenger window is theoretically stylable by the theme, although neither of the default themes set page colours, so you get the appearance defaults.

The HTML compose window is set from preferences, but the plain text compose window uses the appearance defaults. I'm not actually sure that it's possible to change the colours of the plain text compose window.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.