Feature Request: Close tabs to Left/Right

NEW
Unassigned

Status

SeaMonkey
UI Design
--
enhancement
12 years ago
6 years ago

People

(Reporter: Wes Janzen, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity: Fx + TMP])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.10) Gecko/20050728
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.10) Gecko/20050728

It would be nice if the context menu would bring up an option to close tabs to
the left or right of the current tab.  Often when browsing a shopping site or
product information site, I will load the images in a new tab because it is both
quicker (on my admittedly slow machine) and convenient when comparing several
different products.  Some sites don't allow "hot-linking" and won't load the
page when opened that way, I assume this is because the referrer (header?, I
need to brush up on my HTTP knowledge...) isn't set when loading a page in a new
tab.  So, after loading 16 or so pages, I browse to the first one only to find
out that "it can't be found" or maybe it even has a hotlinking message.  Anyway,
it'd be nice to close just those new windows which show up in tabs to the right
of my current tab, rather than having to Ctrl-w (which doesn't respect the
amount of times I hit the key combination BTW).  Right now it's faster just to
bookmark the other windows I have open, lose my history, and close and then
re-open the browser rather than hit Ctrl-W, wait for the page to show, Ctrl-W,
wait for the page to load, ad nauseum...  I'm not sure if anyone else uses the
browser this way but to me it would seem to be more useful and make more sense
to have the left/right feature than the close all other tabs option in the first
place.  Obviously, I think both should be supported an the left/right option
should just be added to the context menu.

Reproducible: Always

Steps to Reproduce:
1.Browse to several different websites.  Later, browse to some more in new tab.
 Browse some more, so now you have five or so tabs your interested in and want
to keep open, but not so important that you want to bookmark them.
2.Open a bunch of tabs for product comparison purposes...
3.Notice that the pages don't load because they don't allow hot-linking...
4.Try to decide whether to close all those other windows to the right of the
current window with Ctrl-W, spending the next 2 minutes waiting for each page to
display before it accepts the Ctrl-W, or just close all the windows and re-open
Mozilla trying to remember how you got to the pages you were viewing in the
other windows, or just live with 2mm tabs until you're done browsing in other
windows, or open a new window for each site so that if you (might) want to do a
comparison from so that if it doesn't allow hot-tabbing you can just close that
window, but then that would almost negate the advantages of tabs in the first place.

Actual Results:  
I cried.  Then I came here.

Expected Results:  
A better tab user interface option than just closing all other tabs.

This is a feature request.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008040701 SeaMonkey/2.0a1pre

Parity: Firefox can do it when equipped with the Tab Mix Plus extension (which is not going to be ported to SeaMonkey).

Currently, SeaMonkey only allows closing _one_ tab at a time; focus will then go to previous (parent) tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
OS: Linux → All
Hardware: PC → All
Whiteboard: [parity: Fx + TMP]
Version: unspecified → Trunk

Comment 2

10 years ago
Created attachment 315259 [details]
feature implemented as a small extension

I implemented the feature as a small extension.
I am not sure about correctness -- can someone with enough knowledge look into it?
This is my first extension, however seems to work. Tested on my Firefox, Seamonkey suite 1.1.7 and current Seamonkey nightlies.

Comment 3

10 years ago
Comment on attachment 315259 [details]
feature implemented as a small extension

(changed the content type, so the attachment doesn't ask to install the extension)
Attachment #315259 - Attachment mime type: application/x-xpinstall → application/octet-stream
Vladislav: I suppose you should request review for your extension (by turning the "review" rolldown of the attachment to "?"). I'm not sure, however, "from whom" the review should be requested. (Neil: maybe you know?)

Comment 5

10 years ago
(In reply to comment #4)
Tony: just checked once more and found that the extension fails to work properly on Firefox :-( I will [try to] correct it and re-upload.

(In reply to comment #5)
> (In reply to comment #4)
> Tony: just checked once more and found that the extension fails to work
> properly on Firefox :-( I will [try to] correct it and re-upload.
> 

On Firefox it's IMHO less important, since the Tab Mix Plus extension already includes that functionality; anyway (IIUC) Firefox's and SeaMonkey's tabbrowsers are significantly different. If it can work OK on SeaMonkey and either work or refuse installing on Firefox, then IMHO it would already be something.

Comment 7

10 years ago
There's no formal review procdure for extensions! However you may be able to drum up some interest in the newsgroups or MozillaZine forums.
(In reply to comment #7)
> There's no formal review procdure for extensions! However you may be able to
> drum up some interest in the newsgroups or MozillaZine forums.
> 

Unless, IIRC, you want to post your extension as a "public" addon at http://addons.mozilla.org/ -- Well, Vladislav, I'm not sure how to go about that; but I suppose you could first post your extension at http://forums.addonsmirror.net/ and/or in the part about extensions in http://forums.mozillazine.org/ then get ready to post it at addons.mozilla.org .

Or -- Neil, do you think that, once this extension "works", there is a chance that it will be integrated into the main product, maybe like the DOM Inspector et al.?

Comment 9

10 years ago
(In reply to comment #8)
> Or -- Neil, do you think that, once this extension "works", there is a chance
> that it will be integrated into the main product
Personally I don't see it being sufficiently useful, but this is a good example of why the whole extension system was developed in the first place.
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392269
Oops, didn't realize this was a SeaMonkey bug. My mistake!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

6 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.