Closed Bug 302880 Opened 19 years ago Closed 19 years ago

crash when select menu has focus, and trying to go back one page

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 302916

People

(Reporter: phiw2, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050731 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050731 Firefox/1.0+

Navigate to page with a form that contains a <select> menu. Select one of the
options (or just put the focus on the select menu). Then try to go back one page
(backbutton or keyboard shortcut). Firefox crashes.

Reproducible: Always

Steps to Reproduce:
1.give focus to a select menu
2.try to go back one page (while the select menu still has focus)
3.

Actual Results:  
Spinning wheel, app doesn't respond for a few seconds, crash.

Expected Results:  
go back one page without crashing.

Talkback ID TB7976730X.

Also noticed that the page isn't registred in the History (not available under
the Go menu) after restarting.

Build 20050730 didn't have this problem.
Definately Mac-specific. 
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050731 Firefox/1.0+ ID:2005073110
I can reproduce this on Linux.

Talkback ID: TB7982193E
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050731
No crash with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050731 Firefox/1.0+ ID:2005073110
Incident ID: 7982193
Stack Signature	nsFocusController::GetWindowFromDocument() 12493257
Product ID	FirefoxTrunk
Build ID	2005073105
Trigger Time	2005-07-31 22:15:06.0
Platform	LinuxIntel
Operating System	Linux 2.6.12-gentoo-r6
Module	firefox-bin + (00474db2)
URL visited	https://bugzilla.mozilla.org/attachment.cgi?id=191166
User Comments	https://bugzilla.mozilla.org/show_bug.cgi?id=302880 Confirming a
crash on Linux :-)
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.
/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsFocusController.cpp,
line 212
Stack Trace 	
nsFocusController::GetWindowFromDocument() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsFocusController.cpp,
line 212]
nsFocusController::GetControllerForCommand() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsFocusController.cpp,
line 202]
nsXULCommandDispatcher::GetControllerForCommand() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/xul/document/src/nsXULCommandDispatcher.cpp,
line 434]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2118]
XPC_WN_CallMethod() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1401]
js_Invoke() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/jsinterp.c,
line 1173]
js_Interpret() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/jsinterp.c,
line 3464]
js_Invoke() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/jsinterp.c,
line 1193]
js_InternalInvoke() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/jsinterp.c,
line 1271]
JS_CallFunctionValue() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/js/src/jsapi.c,
line 3919]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1402]
nsJSEventListener::HandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/events/nsJSEventListener.cpp,
line 175]
nsEventListenerManager::HandleEventSubType() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1590]
nsEventListenerManager::HandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1689]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2201]
nsXULCommandDispatcher::UpdateCommands() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/xul/document/src/nsXULCommandDispatcher.cpp,
line 378]
nsGlobalWindow::UpdateCommands() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 4198]
nsFocusController::UpdateCommands() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsFocusController.cpp,
line 848]
nsFocusController::SetSuppressFocus() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/dom/src/base/nsFocusController.cpp,
line 136]
PresShell::UnsuppressAndInvalidate() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp,
line 5060]
PresShell::UnsuppressPainting() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp,
line 5084]
PresShell::Thaw() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp,
line 226]
nsDocShell::RestorePresentation() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 848]
nsDocShell::InternalLoad() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 6364]
nsDocShell::LoadHistoryEntry() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 119]
nsDocShell::LoadURI() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 842]
nsSHistory::InitiateLoad() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpfe/components/shistory/src/nsSHistory.cpp,
line 842]
nsSHistory::LoadEntry() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpfe/components/shistory/src/nsSHistory.cpp,
line 842]
nsSHistory::GoBack() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpfe/components/shistory/src/nsSHistory.cpp,
line 548]
nsDocShell::GoBack() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 848]
nsEventStateManager::DoScrollHistory() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 848]
nsEventStateManager::PostHandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 2123]
PresShell::HandleEventInternal() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp,
line 848]
PresShell::HandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp,
line 6198]
nsViewManager::HandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/view/src/nsViewManager.cpp,
line 848]
nsViewManager::DispatchEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/view/src/nsViewManager.cpp,
line 2236]
HandleEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/view/src/nsView.cpp,
line 251]
nsCommonWidget::DispatchEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsCommonWidget.cpp,
line 219]
nsWindow::OnScrollEvent() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsWindow.cpp,
line 1806]
scroll_event_cb() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsWindow.cpp,
line 3859]
libgtk-x11-2.0.so.0 + 0x10d9d6 (0xb7c599d6)
libgobject-2.0.so.0 + 0x7a5a (0xb7a33a5a)
libgobject-2.0.so.0 + 0x17fec (0xb7a43fec)
libgobject-2.0.so.0 + 0x16ed5 (0xb7a42ed5)
libgobject-2.0.so.0 + 0x17354 (0xb7a43354)
libgtk-x11-2.0.so.0 + 0x1f1a58 (0xb7d3da58)
libgtk-x11-2.0.so.0 + 0x10c5eb (0xb7c585eb)
libgtk-x11-2.0.so.0 + 0x10b5c1 (0xb7c575c1)
libgdk-x11-2.0.so.0 + 0x3a619 (0xb7b0e619)
libglib-2.0.so.0 + 0x2238d (0xb79ce38d)
libglib-2.0.so.0 + 0x23334 (0xb79cf334)
libglib-2.0.so.0 + 0x23652 (0xb79cf652)
libglib-2.0.so.0 + 0x23b99 (0xb79cfb99)
libgtk-x11-2.0.so.0 + 0x10af15 (0xb7c56f15)
nsAppShell::Run() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 141]
nsAppStartup::Run() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 146]
XRE_main() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 2324]
main() 
[/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 62]
libc.so.6 + 0x1509a (0xb751f09a)


*** This bug has been marked as a duplicate of 302916 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: