crash after selecting link with FAYT and going back [@ nsFocusController::GetWindowFromDocument] [@ nsPIDOMWindow::IsInnerWindow]

RESOLVED DUPLICATE of bug 302916

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 302916
13 years ago
13 years ago

People

(Reporter: Andrew Schultz, Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
Linux
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
With linux seamonkey build 2005073110, if I use find-as-you-type to select a
link and then go back, it crashes.  This didn't happen with yesterday's build
(2005073005), so it would appear to be a regression from bug 296639.  I'll
attach a testcase.
(Reporter)

Comment 1

13 years ago
Created attachment 191169 [details]
testcase

1. load the testcase
2. click on the link
3. use type ahead find to search for "search"
4. click the back button
==> crash
(Reporter)

Comment 2

13 years ago
Created attachment 191170 [details]
stacktrace
(Reporter)

Updated

13 years ago
Summary: crash after selecting link with FAYT and going back [@ nsFocusController::GetWindowFromDocument] → crash after selecting link with FAYT and going back [@ nsFocusController::GetWindowFromDocument] [@ nsPIDOMWindow::IsInnerWindow]
(Reporter)

Updated

13 years ago
Flags: blocking1.8b4?
No crash here with WinXP. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b4) Gecko/20050731 Firefox/1.0+ ID:2005073122
Blocks: 296639
No longer depends on: 296639

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 302916 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Flags: blocking1.8b4?
Crash Signature: [@ nsFocusController::GetWindowFromDocument] [@ nsPIDOMWindow::IsInnerWindow]
You need to log in before you can comment on or make changes to this bug.