More linking issues with SVG causing "crashes" (no FcPatternCreate)

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: bzbarsky, Assigned: budek)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
STEPS TO REPRODUCE:

1)  Make a GTK1 SVG build.
2)  Load http://www.hixie.ch/tests/adhoc/svg/perf/001.xml

EXPECTED RESULTS: SVG renders

ACTUAL RESULTS: relocation error:
/home/bzbarsky/mozilla/profile/obj-opt/dist/bin/components/libgklayout.so:
undefined symbol: FcPatternCreate

This is sort of keeping me from profiling the testcase in bug 296058, since my
profiling-enabled build dies...
(Assignee)

Comment 1

13 years ago
cairo seems to need libfontconfig. I added -lfontconfig in config/autoconf.mk after running configure:

MOZ_CAIRO_LIBS = -lmozcairo -lmozlibpixman  -L/usr/X11R6/lib -lfontconfig -lXrender -lfreetype
(Reporter)

Comment 2

13 years ago
Created attachment 207550 [details] [diff] [review]
Hans-Peter's proposed patch
Attachment #207550 - Flags: review?(benjamin)
(Reporter)

Comment 3

13 years ago
With that patch, I only hit the crash from bug 299568 here (and the patch proposed there fixes that crash too).

Updated

13 years ago
Attachment #207550 - Flags: review?(benjamin) → review?(tor)

Comment 4

13 years ago
Somebody who knows cairo should review this, I don't know what it might imply.

Updated

13 years ago
Attachment #207550 - Flags: review?(tor) → review+
(Reporter)

Updated

13 years ago
Assignee: general → budek
(Reporter)

Comment 5

13 years ago
Checked in to the trunk.  Hans-Peter, thank you for the patch!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.