Cannot build installer without Cygwin

RESOLVED FIXED

Status

defect
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: mbockelkamp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
The installer build script depends on cygpath being present in xptlink.pl, which
means that the installer cannot be built when using Msys without also installing
Cygwin.
*** Bug 302993 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: bugzilla → general

Comment 2

12 years ago
Is this still an issue now that we use NSIS for generating the installer?

Comment 3

12 years ago
This was fixed here: http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/xpinstall/packager/xptlink.pl&mark=1.11
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Does the installer build with MSYS Perl? Last time I looked, there were some XCOPY commands which MSYS Perl has trouble executing.

Comment 5

12 years ago
I'm pretty sure it does, as I've been using msys-based build environments for a while and have definitely built installers.
You need to log in before you can comment on or make changes to this bug.