remove "close" button (the x) from download manager, place "hide" button in ui

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
trivial
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: Aaron Slunt, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050801 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050801 Firefox/1.0+

Currently, when hitting the close button in the download manager, the downloads
continue. The close button is misleading in this case, as it appears to mean
that all downloads will be closed too, when in fact this is not happening.

Removing the close button in the framebar and placing a "hide" button (next to
Clean Up seems right to me) in the UI will remove any confusion about this.

Reproducible: Always
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
Note that there's some overlap here with bug 300925
So, some things that are interesting here:

- if there's no browser window open, closing the DM *does* close the firefox
process (on all platforms except Mac) and stops the downloads

- this isn't a downloader, but rather a download monitor/manager (although
that's a hard disinction to pass on to a user)

- there may be a desire to see some indication that the browser is downloading
from the browser window itself (bug 245567)

- our current behaviour is standard with other browsers that use download
managers (Safari, Camino, Opera, Seamonkey)

It seems to me that what we want to do it make it crystal clear to the user that
this window is a *view* on their current and past downloads, not a master
controller. Some potential ways of doing this:

1) show some "downloading 3 files" status info in the already-crowded status bar
2) get rid of the close button and make it a hide button, but normal close UI
accelerators (ie: alt+f4) would cause the window to hide
3) pop a dialog on the first time explaining that although the window is closed,
downloads continue (ugh, but it has the advantage of being REALLY clear,
assuming anyone reads it)

Comment 3

13 years ago
"- if there's no browser window open, closing the DM *does* close the firefox
process (on all platforms except Mac) and stops the downloads"
That's just a lucky break from the default behavior of all sane apps closing
themselves when all the windows have been closed. =P
As a slightly above average user I disagree that it is misleading, anyone will
figure it out after once.  I think the problem is that it isn't necessarily
apparent to everyone that this is a download monitor/manager a la extension
manager. I think the solution is to make this more clear rather than making the
expected behavior different between these two managers.

Personally I think adding a "Cancel All Downloads" button beside "Clean Up"
would indicate that you have to click that button and not the X to cancel
downloads. If that isn't enough why don't we just call the thing Download Monitor?
Status: UNCONFIRMED → NEW
Ever confirmed: true
We have this displaying in the statusbar now, and I agree with comment 4.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.