firefox receives SIGKILL if it runned under debugger in few seconds after main firefox window is displayed

RESOLVED INVALID

Status

()

Firefox
General
--
blocker
RESOLVED INVALID
13 years ago
8 years ago

People

(Reporter: Alexandr Chujko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Slackware 10.0, glibc-2.3.2.
Seems like something with libthread_db.so/libthread.so.

firefox -g
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) prun  
Breakpoint 2 at 0x8057eb1: file nsBrowserApp.cpp, line 58.  
main (argc=1, argv=0xbfda87d4) at nsBrowserApp.cpp:58  
Type Manifest File: /root/.mozilla/firefox/6fjrdnbr.default/xpti.dat  
nsNativeComponentLoader: autoregistering begins.  
nsNativeComponentLoader: SelfRegisterDll(libp3p.so) Load FAILED with  
error: /usr/local/lib/firefox-1.0.4/components/libp3p.so: undefined  
symbol: _ZTI23nsSupportsWeakReference  
nsNativeComponentLoader: SelfRegisterDll(libtypeaheadfind.so) Load  
FAILED with error:  
/usr/local/lib/firefox-1.0.4/components/libtypeaheadfind.so: undefined  
symbol: _ZTI23nsSupportsWeakReference  
nsNativeComponentLoader: SelfRegisterDll(libwallet.so) Load FAILED with  
error: /usr/local/lib/firefox-1.0.4/components/libwallet.so: undefined  
symbol: _ZTI23nsSupportsWeakReference  
nsNativeComponentLoader: SelfRegisterDll(libspellchecker.so) Load FAILED  
with error: /usr/local/lib/firefox-1.0.4/components/libspellchecker.so:  
undefined symbol: _ZTI23nsSupportsWeakReference  
nsNativeComponentLoader: autoregistering succeeded  
nNCL: registering deferred (0)  
GFX: dpi=75 t2p=0.0526316 p2t=19 depth=24  
++WEBSHELL == 1  
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file  
nsPermissionManager.cpp, line 623  
++DOMWINDOW == 1  
++WEBSHELL == 2  
++DOMWINDOW == 2  
bad FastLoad file checksum  
Note: styleverifytree is disabled  
Note: frameverifytree is disabled  
WARNING: the property eo already exists  
, file nsPersistentProperties.cpp, line 282  
Note: verifyreflow is disabled  
WARNING: GetDefaultCharsetForLocale: need to add multi locale support,  
file nsUNIXCharset.cpp, line 189  
WARNING: GetDefaultCharsetForLocale: need to add multi locale support,  
file nsUNIXCharset.cpp, line 189  
++WEBSHELL == 3  
++DOMWINDOW == 3  
###!!! ASSERTION: should have made area frame for this: 'aRelPos', file  
nsCSSFrameConstructor.cpp, line 12518  
Break: at file nsCSSFrameConstructor.cpp, line 12518  
^G  
Program terminated with signal SIGKILL, Killed.  
The program no longer exists.

If i cretate thread in my xpcom like this:
NS_NewThread(getter_AddRefs(mThread), this, 0, PR_UNJOINABLE_THREAD);
firefox reveives signall 11 and crushed too.


Reproducible: Always

Steps to Reproduce:
1. type firefox -g
2. type run

Actual Results:  
firefox killed

Expected Results:  
firefox runned

I`ll give any additional information if needed.

*** This bug has been marked as a duplicate of 303051 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

13 years ago
i think this concerned to this bug also: 
i have such code 
 
NS_IMPL_THREADSAFE_ISUPPORTS1(nsMySqlConnection, nsIRunnable) 
 
nsresult nsMySqlConnection::Init() 
{ 
   PR_LOG(brLog::nsmodule, PR_LOG_DEBUG, ("%s IN", __FUNCTION__)); 
   if (!mThread) 
   { 
       nsresult rv = NS_NewThread(getter_AddRefs(mThread), 
                                  NS_STATIC_CAST(nsIRunnable*, this)); 
       NS_ENSURE_SUCCESS (rv, rv); 
   } 
   PR_LOG(brLog::nsmodule, PR_LOG_DEBUG, ("%s OUT", __FUNCTION__)); 
   return NS_OK; 
} 
 
NS_IMETHODIMP nsMySqlConnection::Run() 
{ 
   PR_LOG(brLog::nsmodule, PR_LOG_DEBUG, ("In THREAD %s", __FUNCTION__)); 
   return NS_OK; 
} 
 
And if i call Init function: 
------------------------ release firefox version ------------------------ 
firefox output: 
./run-mozilla.sh: line 451:  3701 Killed                  "$prog" ${1+"$@"} 
 
log: 
16384[899ff80]: Init IN 
16384[899ff80]: Init OUT 
 
------------------------ debug firefox version ------------------------ 
firefox output: 
Program /usr/local/lib/firefox-1.0.4/firefox-bin (pid = 2210) received signal 
11. 
Stack: 
_ZN13nsProfileLock18FatalSignalHandlerEi+0x00000137 
[/usr/local/lib/firefox-1.0.4/firefox-bin +0x00027A15] 
UNKNOWN [/lib/libpthread.so.0 +0x0000BBE5] 
UNKNOWN [/lib/libc.so.6 +0x00029078] 
UNKNOWN [/usr/local/lib/firefox-1.0.4/libnspr4.so +0x00030448] 
UNKNOWN [/lib/libpthread.so.0 +0x00005CC4] 
Sleeping for 5 minutes. 
Type 'gdb /usr/local/lib/firefox-1.0.4/firefox-bin 2210' to attach your 
debugger to this thread. 
 
log: 
16384[8077618]: Init IN 
16384[8077618]: Init OUT 
16384[8077618]: WARNING: requested removal of nonexistent window 
, file nsWindowWatcher.cpp, line 944 
16384[8077618]: Observe: topic - xpcom-shutdown, data - (null) 
16384[8077618]: WARNING: nsExceptionService ignoring thread destruction after 
shutdown, file nsExceptionService.cpp, line 191 
16384[8077618]: WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file 
nsGlobalHistory.cpp, line 2520 
16384[8077618]: WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(OpenDB())) failed, file 
nsGlobalHistory.cpp, line 1221  
 
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago
*** Bug 303051 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
I'm trying to debug my continuous crashes of Firefox, current nightly build, since talkback is not working in Linux.

I can confirm this issue.

See comments on bug 246557

Comment 5

10 years ago
Since Bug 303051 has been resolved, shouldn't this be marked as resolved as well?
Alexandr, please file a new bug if this still occurs in an *unchanged*
mozilla-central build.  If you make changes to the source that cause
it to crash it's better to ask for help in the news groups.
http://www.mozilla.org/community/developer-forums.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.