Unable to install any extension if no extensions are yet installed

RESOLVED DUPLICATE of bug 300442

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 300442
13 years ago
10 years ago

People

(Reporter: cyril, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

If extensions list is empty (EG: fresh clean install) then trying to install any
extension does nothing. Javascript console though reports a problem at
richlistbox.xml line #171 (as of Deer Park Alpha 2):

this.scrollBoxObject.scrollToElement(this.selectedItem);

Changing this to:

if (this.selectedItem)
  this.scrollBoxObject.scrollToElement(this.selectedItem);

seems to fix the problem.



Reproducible: Always

Steps to Reproduce:
1. Clean install (Deer Park A2)
2. Try to install any extension any way (seemingly)
3. No profit.

Actual Results:  
Exactly nothing

Expected Results:  
Install the extension
Doron, care to look at this?

*** This bug has been marked as a duplicate of 300442 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.