"Save as" for attachment in forwarded mail produces garbage if "Display attachments inline" is unchecked

RESOLVED DUPLICATE of bug 296560

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 296560
13 years ago
13 years ago

People

(Reporter: Michael Teske, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0
Build Identifier: 1.0.6

When one has "Display Attachments inline" off and one opens a mail which
contains a forwarded mail (as attachment) which has attachments itself, if one
opens that attached mail and tries to save such an attachment, all one gets is 
a file which contains just 
</body>
</html>

Strangely enough, "Open" works.

Reproducible: Always

Steps to Reproduce:
1. Switch "View/Display Attachments Inline" off
2. Compose a mail to yourself containing an attachment, e.g. a .jpg file
3. having received the mail from 2., forward it to yourself by using
"Message/Forward as attachment"
4. having received the forwarded mail, open the attached message using the richt
mous button
5. in the newly opened window save the attached file within this mail, e.g. the
jpg-image, to disk.
Actual Results:  
The saved file contains garbage, usually just
</body>
</html>

Expected Results:  
It should save the file correctly.
(Reporter)

Comment 1

13 years ago
I tried with the latest build but this will coredump when trying to open the
forwarded message. 
Mozilla 1.6 doesn't seem to have this problem.

Comment 2

13 years ago
version 1.0+ (20050731)

I can't reproduce this because when I do, I'm getting bug 203570.
(Reporter)

Comment 3

13 years ago
Ok, I use imap, that's probably why bug 203570 doesn't come into play (at least
is says so there).

BTW, a friend of mine could reproduce it on windows as well.

Comment 4

13 years ago
Duplicate of bug 296560?
(Reporter)

Comment 5

13 years ago
arrghh, you're right. I swear I searched the bug database, but did not find it.
Now I find it immediately, of course. But someone needs to record in bug 296560
that this only happens when "Display Attachments Inline" is off.

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 296560 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.