Page doesn't print properly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: steve.kelem, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

The example page renders properly inside the Firefox browser.
When printing (to a color postscript xerox 8400), the page prints very badly.
Under page setup, I chose Print Background (colors & images).
1. The title bar prints by itself on the first page, but the bar doesn't extend
all the way across the page.
2. A few images from the web page print on the second printed page.
3. Some other image prints on the 3rd printed page.
4. The text doesn't print on any page.

Reproducible: Always

Steps to Reproduce:
1.Click on the above link.
2.Under Page Setup, click on Print Background.
3.Print (to printer or file).

Actual Results:  
It doesn't print properly--instead of printing on one page, as rendered in the
browser, it prints only some of the page elements, and they're spread across 3
pages.

Expected Results:  
Printed a page resembling the one rendered in the browser.
(Reporter)

Comment 1

13 years ago
Created attachment 191341 [details]
File/Print/to ps file/ps2pdf
Component: General → Printing
Product: Firefox → Toolkit

Comment 2

13 years ago
Reproducible, I see the 3 pages in Print Preview with Mozilla 1.8b1, Deer Park
a2 and SeaMonkey/20050727, (un)setting Print Background doesn't seem to change
the position of the images.
Assignee: nobody → printing
Component: Printing → Printing
Product: Toolkit → Core
QA Contact: general
Version: unspecified → Trunk
Assignee: printing → nobody
QA Contact: printing

Comment 3

9 years ago
Same issue with numerous pages.
For example:  http://support.nikontech.com/app/answers/print/a_id/6197/kw/accessories/p/1%2C11/c/176/r_id/116678

I have tried printing this to a B&W vintage HP Laser, a new HP Color InkJet, and my Adobe Acrobat convertor, all in perfect working order.  If I use the print link on the page I get one page and none of the rest.  If I use the browser menu print, I get the same mis-distributed three pages out of one page; and all the rest of the browser data is missing.

Printing works perfectly from IE8, so it does not appear to be a significant web design issue.

Comment 4

9 years ago
Created attachment 420928 [details]
This is what should get printed (printed from IE8)

This is the first of two images.  This one shows what should be printing.  The second one shows what actually prints.

Comment 5

9 years ago
Created attachment 420929 [details]
This is what should get printed (printed from IE8)

This is the first of two images.  This one shows what should be printing.  The second one shows what actually prints.  (Note: earlier attachment was mislabeled as a JPG)

Comment 6

9 years ago
Created attachment 420930 [details]
This is what actually gets printed (printed from FF3.6)

This is the second of two images.  This one shows what should be printing.  The second one shows what actually prints.
Attachment #420928 - Attachment is obsolete: true
In today's Firefox 3.6pre build on Ubuntu, I get slightly different output, but it's still 1 page instead of many -- so, confirmed broken there.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2pre) Gecko/20100110 Namoroka/3.6pre

However, in today's mozilla-central nightly build, I get correct output (4 pages, nothing truncated.)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100107 Minefield/3.7a1pre

So, this was apparently fixed on trunk since (1.9.2) 3.6 branched off.  Resolving as WORKSFORME on trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Original URL (about Helium) is WORKSFORME in *both* Firefox 3.6pre and mozilla-central trunk, too. (see build IDs in previous comment)

All the content is printed, and it ends up being just over 1 page (The "Elements A-Z" dropdown and flash banner below it are the only things pushed to the second page).  Looks much better than the first attachment here.
You need to log in before you can comment on or make changes to this bug.