flash function "loadMovie" fails to load local jpg/swf files

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 84128
12 years ago
12 years ago

People

(Reporter: Niel Drummond, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050711 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050711 Firefox/1.0+

If using the 'loadMovie' function in actionscript for Flash MX (version 6) to
load a local movie or jpg from the local filesystem, the latest builds of
mozilla will fail to load the movie.  

The normal behaviour is to load a swf or jpg, much like the @import function in
javascript (and other programming languages).

It is possible that files being loaded with the "file://" prefix, are being ignored.


Reproducible: Always

Steps to Reproduce:
1. Go To http://dev.lookfantastic.com/hairstyles/index.php
2. Upload a non-progressive jpg to the site using the form


Actual Results:  
12 seconds will pass before the uploaded image is viewable. 

the flash plugin attempts to open the file locally first, but because it fails,
it will load the online version

Expected Results:  
The image should be viewable immediately (try with earlier version of mozilla,
or different browser)

The browsers affected are the latest builds on Firefox, Mozilla in both WinXP
(Firefox 20050711) and Linux using clean profiles. One recent build _unaffected_
is firefox 1.0 (20041107). All tests were done using flash player version 7.

Please also note, the example requires javascript and cookies. It is also under
heavy development, and may change its behaviour in future.

Comment 1

12 years ago
Related to/duplicate of bug 302426 -> bug 84128?
(Reporter)

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.