Space character in "Your Name" field disappears before and after | character (vertical line character)

RESOLVED INCOMPLETE

Status

Thunderbird
Account Manager
--
major
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: Marcus, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-21, URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

tested using Thunderbird version 1.0+ (20050730)

A picture sais more than 1000 words, that's why I've created a screenshot to
illustrate the problem. 

if you enter the vertical line character as "Your Name" under account settings,
spaces before and after that character get deleted when sending the message.

it is problematic because it is quite popular to use that character to separate
the name of a person from the company name. 

Reproducible: Always

Steps to Reproduce:
1. go to account settings
2. enter in field Your Name: "James Brown | Green Corporation"
3. send an email to yourself
4. check your inbox and you will find that the two spaces before and after the
vertical line character have not been sent
(Reporter)

Comment 1

13 years ago
Created attachment 191392 [details]
screenshot illustrating the problem

Comment 2

13 years ago
This works for me in both 1.0.6 and today's trunk.
(Reporter)

Comment 3

13 years ago
If it doesn't fail on you, it must be triggered by specific settings on my
machine. I played aroung a little bit. First, I thought it's because I've set my
default character encoding for outgoing mail to UTF-8. I changed it to Western
but the problem persists. I will attach my prefs.js in case that is of any
interest for you. Let me know if I can provide further information. 

The problem is not new though. It's been like this through all builds since 1.0
and probably earlier. 
(Reporter)

Comment 4

13 years ago
Created attachment 191460 [details]
prefs.js of my TB installation
QA Contact: account-manager
Reporter, does the issue still exist in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest 2.0.0.x is version 2.0.0.16)
Whiteboard: closeme 2008-08-21
RESO INCO per lack of response to previous comment. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.