Bad Flash performance at Wetter.at, most evident in Camino

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: bugmail, Assigned: mikepinkerton)

Tracking

({perf})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Camino 0.9a2 suffers particularly bad performance showing <http://wetter.at/>.
The animations run very roughly, and interact with the cursor extremely
sluggishly. Firefox DPa2 also suffers, though not quite as badly as Camino.

Safari offers much better performance, and iCab 3.0 beta 280 better still.

Reported using a TiBook G4/667.
(Reporter)

Comment 1

14 years ago
Created attachment 191394 [details]
Approximately five seconds of Sampler data recorded while Camino 0.9a2 was displaying Wetter.at
There have also been scattered reports of this in the forums, which has been
puzzling.

I wonder, though, if the recent fixes to make typing passable again have
negatively impacted Flash?
Keywords: perf

Comment 3

13 years ago
2005042806 (v0.8.4)

Mac OS X Jaguar X.ii.vi

I am seeing poor performance on the Inquirer site, e.g.
http://www.theinquirer.net/?article=26743

If all I do is load this page, then Camino takes up t0 70%
of CPU time, but the cursor is not affected. If I load other pages
at the same time (Windows or Tabs), then the cursor is pretty
much unusable in those (unable to drag links et cetera).

I will look again when there is a beta.

Comment 4

13 years ago
Tested today with the following trunk build:  Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051025 Camino/1.0+ .

Performance on the URL in question with this build more usable than on the bug I filed, # 310222.  I was able to navigate the site without having to force-quit.  I did, however, see the beachball pop up several times as Camino caught up to the page elements.

I'll admit I don't know enough about the code to make a judgment on whether these two bugs are out of the same patch of code, judging from the sampler logs on both bugs.

Comment 5

13 years ago
(In reply to comment #3)
> 2005042806 (v0.8.4)
> 
> Mac OS X Jaguar X.ii.vi
> 
> I am seeing poor performance on the Inquirer site, e.g.
> http://www.theinquirer.net/?article=26743
> 
> If all I do is load this page, then Camino takes up to 70%
> of CPU time, but the cursor is not affected. If I load other pages
> at the same time (Windows or Tabs), then the cursor is pretty
> much unusable in those (unable to drag links et cetera).
> 
> I will look again when there is a beta.

2005110708 (v1.0b1)

Mac OS X Panther X.iii.ix . Still in!

Comment 6

13 years ago
(In reply to comment #0)
> Camino 0.9a2 suffers particularly bad performance showing 
> <http://wetter.at/>.
> The animations run very roughly, and interact with the cursor extremely
> sluggishly. Firefox DPa2 also suffers, though not quite as badly as Camino.
> 
> Safari offers much better performance, and iCab 3.0 beta 280 better still.
> 
> Reported using a TiBook G4/667.

2005110708 (v1.0b1)

Mac OS X Panther X.iii.ix . Still in!
The wetter.at site has a scrolling ticker in Flash, and it feels like sites that have scrolling tickers that aren't Flash (which is to say, sloooow; bug 166932 via bug 280982).

The Inquirer page has two or more Flash ads (if you turn ad-blocking off), but even though the CPU usage was about the same (or higher) than wetter.at, I noticed very little slowdown/usability decrease.
See also the URL from bug 321321, which reportedly was terribly slow on older Macs.
I had a look at this site, as well as the one from bug 328488, in my 0.8.4+ build, and we've regressed significantly since 0.8.4 in informal testing.  Flash was slow but useable then, whereas now a scrolling ticker will really eat all the cycles and not let any other events (like a scrollbar move, or even cmd-w!) through for a long time. :-(
*** Bug 334885 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
This looks to be hugely improved on trunk, so closing WFM. If anyone is still seeing unacceptable performance on trunk, feel free to re-open.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.