Display of Submenus from Right-Click Context Menu Entries (Added by Extensions) Enable Back and Forward Context Menu Entries, Even If the Current Page Has No Back/Forward History

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Timothy P. Wolfe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When making use of the entries in the right-click context menu, the Back and
Forward menu entries are only enabled if the currently-viewed page has a
back/foward history - otherwise, those menu entries are disabled.

However, if an extension is installed that adds a context menu entry that
contains a submenu, and the cursor is placed over that entry to expand the
submenu, then both the Back and Forward context menu entries are enabled,
regardless of whether or not the page has a back/forward history.

Reproducible: Always

Steps to Reproduce:
1. Install an extension that will add a right-click context menu entry that
contains a submenu for more functions (such as Tab Mix Plus, Linky, View
Formatted Source, etc.).
2. Right-click on a page that either has no history, or either back or forward
history (but not both).
3. Move your cursor over one of the extension-added context menu entries that
has a submenu.
Actual Results:  
The Back and Forward entries are both enabled, regardless of whether or not the
page has a back/forward history.

Expected Results:  
The Back and Forward entries should only be enabled if the page has a
back/forward history - otherwise, they should remain disabled.

Comment 1

13 years ago
Reporter, can you confirm that this is still happening to you?  Does it only
occur when you have more than one tab open?  Can it only occur when there's a
single tab open?  Can you try installing the latest 1.0.6 build, available at
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/

WFM, I don't see the problem on WinXP SP2, Deer Park Alpha 2, View Formatted
Source extension installed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050809
Firefox/1.0+
(Reporter)

Comment 2

13 years ago
I tried this out again, and it happens regardless of whether I have more than
one tab open, or just one tab open.

I also went ahead and used a cleaned-out "testing" profile (only installing one
or two extensions with context menu submenus so I can test this) to make sure it
wasn't a profile issue - it occurs there, too.

After this, I did as you said and installed the most recent 1.0.6 nightly
(20050810, same profile as before) - it still happens.

I then noticed that you also said you were using Deer Park Alpha 2, so I went
ahead and installed the most recent version of it (again, using the same profile
as I did before)...This time, though, it didn't happen.

Since it works with Deer Park Alpha 2, maybe only the 1.0.x versions (and
possibly earlier versions of Deer Park) are affected by this?
(Reporter)

Comment 3

13 years ago
This is strange...After uninstalling both Deer Park Alpha 2 and the Firefox
1.0.6 nightly that I installed earlier, and reinstalling the official Firefox
1.0.6, this problem doesn't occur anymore, in any of my profiles.

Could it be possible that something was left over from a previous installation
of Firefox that was causing this, which was then fixed by uninstalling and
reinstalling it (as opposed to just upgrading an older version without
uninstalling the previous one)?

I'm not sure why uninstalling it before now didn't fix this, but for some
reason, this time it fixed the problem.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.