There should be an icon to deactivate playing of sound

RESOLVED DUPLICATE of bug 24418

Status

RESOLVED DUPLICATE of bug 24418
13 years ago
5 years ago

People

(Reporter: Thomas.Lange, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511

Lately the number of webpages playing unwanted or annoying sound-effects or even
bad fulltime background sound have risen.

Turning on/off sound in the OS does effect other applications as well which
should not happen.

I suggest to add an icon in the status bar that can be used to switch playing
sound on off. 
I'm not sure though if that icon should work on a per-page basis or as general
control for all (tab)pages.

If there would also be another image for the same icon to indicate that the
actual displayed (tab)page is currently playing sound would be nice too.

Some kind of volume control could be considered as well though I do not find it
necessary.

Also an option for the user to specify if playing sound should be enabled by
default would be nice as well.


Reproducible: Always

Comment 1

13 years ago
first of all, this bug is absolutely useless as a cross platform bug.
second, on some platforms there are n (where n is a non enumerable and 
unpredictable number) different unrelated apis that allow for the control or 
play of sound. as such on such platforms it's essentially impossible for 
mozilla to do this.
third, this is a duplicate
fourth, on some platforms trying to use the sound apis will lock out other 
applications, which would be really bad, especially if you were just trying to 
mute the one application.
Whiteboard: DUPEME

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 24418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.