Should be able to click and drag to select multiple downloads in Downloads window

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
13 years ago
4 years ago

People

(Reporter: nick.kreeger, Assigned: ishermandom+bugs)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Should be able to click-hold and then select downloads in the download manager.
This should work like select-clicking. Currently when you click-hold and try to
select more downloads, the manager will only select the first instance that was
clicked on originally.

Reproducible: Always

Steps to Reproduce:
1.Start 2 > downloads
2.Try to click-hold and select those downloads
3.

Actual Results:  
Only the first download was selected

Expected Results:  
Should have selected all the downloads that the mouse was draggeed over
Confirming as RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Updating summary...
Summary: Should be able to click-hold and select downloads in download manager → Should be able to click-hold/shift-click and select downloads in download manager
*** Bug 304016 has been marked as a duplicate of this bug. ***
-> kreeger
Assignee: pinkerton → nick.kreeger
Cmd-A should also work here, when the DM has focus.

Comment 6

13 years ago
This is all caused by the fact that it's not a real NSTable view, if it was it would just look and behave like all the table views apps normally use, or like we do in boomarks.

Comment 7

12 years ago
Targeting to 1.2 with the rest of our DL manager bugs. Stuart said something recently about making this a real NSTable view, I think.
Target Milestone: --- → Camino1.2

Updated

12 years ago
Target Milestone: Camino1.6 → ---
Would be great if someone could look into this, now that the new download window is in place. The same problem the original reporter described applies here, only that now the last-clicked element is the one that gets selected.

Comment 9

11 years ago
There is no new download window; you are probably looking for a bug against a product other than Camino.
Woa... sorry. I meant to search firefox bugs...
(Assignee)

Comment 11

9 years ago
Tentatively taking; though if someone else wants to try this, don't be shy ;)
Assignee: nick.kreeger → ishermandom+bugs
Ilya's fixed both Shift-click and Cmd-A at some point along the 2.0 road.

Re-summarizing to make this just about click-drag (and note that as of 10.5, click-drag in list/outline-view type stuff in the OS, e.g. a Finder window in list view, requires that you click and drag in empty space where there is no text).

Ilya mentions this will probably be difficult:

[11:50pm] ilya: it looks like that bug should be about equally hard to do relative to the multi-drag bug
[11:51pm] ilya: they both suffer from not having any view object corresponding to the whole list
QA Contact: downloading
Hardware: PowerPC → All
Summary: Should be able to click-hold/shift-click and select downloads in download manager → Should be able to click and drag to select multiple downloads in Downloads window
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.