Gecko Core lacks options for cache (A request for better cache policy)

RESOLVED WONTFIX

Status

()

Core
Networking: Cache
--
enhancement
RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: Artem S. Tashkinov, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050728 Firefox/1.0+

I would like to save more traffic by forcing gecko not update its cache for
documents other than text/html and simple text. So I would like Mozilla Firefox
has an option like:
"Keep in sync only dynamic content".

After this option has been activated Gecko won't update CSS/Images/JS etc.
documents.

Speaking frankly I would like there be all options like in Opera 8.x. Don't beat
me for that.

Reproducible: Always

Comment 1

13 years ago
I'm not against making the caching policy more configurable for advanced users
or application developers, but I have to say that this is very far from the top
of my priority list, so I will most likely never work on this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future

Comment 2

12 years ago
I agree with this.  Images are rarely, if not ever, updated.  Whereas text/html is.

I thought of something similar the other day - http://forums.mozillazine.org/viewtopic.php?t=393050


This would for sure speed up Firefox, and make many sysadmins happy because it will drastically reduces bandwidth.

I have noticed Opera 9.0 has a similar feature to what we are thinking. 

Updated

12 years ago
Assignee: darin → nobody
Target Milestone: Future → ---
addon material
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.