"Reply all" reply to myself too

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Claude Fortier, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Thunderbird version 1.0.6 (20050716)

If you receive a message with multiple recipient on the "To:" field, clicking on
"Reply all" will add yourself to the "Cc:" list.

I don't think it should send a copy of an email I send to myself...

Reproducible: Always

Steps to Reproduce:
1. Find a message you received with multiple receipient.
2. Clic on "Reply all".
Actual Results:  
My email will be added to the "Cc:" lit.


Expected Results:  
My email should not be in the "Cc:" list.

There is a workaround: remove de "Cc:" line with the address. But you have to
remember to do so and it's annoying.

Comment 1

13 years ago
bug 85296 ?

Comment 2

13 years ago
no, I don't think so - that user is pressing reply on a message in his own sent
folder. This user wants his own address stripped off when doing a reply all -
which in fact, we do...my guess is that the e-mail was redirected to him by a
server, so that we can't tell that his current e-mail address is the same as the
e-mail was sent to.
(Reporter)

Comment 3

13 years ago
Oh, my fault. I recently had to change my email from "claude_fortier@..." to
"claude.fortier@..." (the _ change to a .). But my contacts did not made that
change and both address still works.

So I guess for thunderbird, "claude_fortier@..." is not me because my current
address is the one with the dot. But because both address still work, I receive
my reply to myself.

Sorry for this false bug, and thank to David Bienvenu to made me think about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 4

11 years ago
I kinda have this, for other reasons.
My company has aliases for me, I'm jsmith@employer.com and john.smith@employer.com.
People email either and they get to me.
However, I've set up the account in TB as john.smith@employer.com.
Reply-alls to emails sent to jsmith@employer.com include jsmith@employer.com in the recipients. :-(
I figured I could add an Identity under that account and jsmith@employer.com would not get added to reply-all- recipients, but no, I'm still there. :-(
You need to log in before you can comment on or make changes to this bug.