table cells content will not be rendered correctly

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: Benjamin Kalytta, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50215)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

In the page http://www.kalytta.com/bugs/test.table.html table cells content 
will not be rendered correctly. For example <img src="test.gif" width="100%" 
height="100%" alt="test"> will not fully span the tables cell space as you can 
see with the image below cell 2.8 and below cell 4.6

Reproducible: Always

Steps to Reproduce:
1. Just create a table with some rowspans and add an image with width/height = 
100% as shown on http://www.kalytta.com/bugs/test.table.html
Actual Results:  
Page is not correctly rendered

Expected Results:  
Image should span full table cell in height and width because 100% was 
specified in both directions.
(Reporter)

Comment 1

13 years ago
Created attachment 191521 [details]
testcase
(Reporter)

Comment 2

13 years ago
Created attachment 191522 [details]
3x3 pixel test image

This image should be stretched to fill entire table cell
(Reporter)

Comment 3

13 years ago
Comment on attachment 191521 [details]
testcase

Main test html file which produces this incorret output
Attachment #191521 - Attachment description: Main test html file which produces this incorret output → test file

Comment 4

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050803 Firefox/1.0+
ID:2005080313

The file you linked to on your site looks fine to me.
(Reporter)

Comment 5

13 years ago
Created attachment 191581 [details]
rendered output

This image show how the content is rendered here. You'll see that bottom 2
images will not span the entire cell in height.
(Reporter)

Comment 6

13 years ago
Created attachment 191595 [details]
expected output

This is the expected rendering result.
(Reporter)

Updated

13 years ago
Attachment #191521 - Attachment description: test file → testcase
(Reporter)

Comment 7

10 years ago
The bug is already there. Will this not be fixed some day? It's 2 yers old now.

Comment 8

9 years ago
(In reply to comment #7)
> The bug is already there. Will this not be fixed some day? It's 2 yers old now.

You reported the bug, so it's on the dev's radar. However, there are more important things to work on. Crying about an aging report won't help. The opposite is true: The more you "cry" the more you annoy the developers.

Hm, actually this is no bug at all.

The images simply end up becoming as wide as the table cell allows.
Because the images' width and height values become 'auto' per CSS, as their containing block's (the td's) height is not set, the images simply expand in a 1:1 ratio to fit the available width without caring about the available height.

Hm, I see that IE7 (also the latest IE8 beta) and Opera act like Firefox, did IE6 something else?

Only Safari acts strange, but that seems to be the real bug.

Thanks for reporting anyway. Maybe in the future you'll be able to create tables like these, but for now we all have to live with a horribly underspecified table system.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.