[Mac] Crash switching between PowerPC and Intel builds

RESOLVED WORKSFORME

Status

()

Firefox
Build Config
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jesse Ruderman, Assigned: Josh Aas)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Steps to reproduce:
1. Acquire an Intel-based Mac.
2. Download a PowerPC (normal) build of Firefox.
3. Download an Intel build of Firefox.
4. Run the Intel build, then run the PowerPC build.
  Result: Crash.
5. Run the PowerPC build, then run the Intel build.
  Result: Crash (sometimes caught by Talkback, sometimes silent).

These crashes only happen on the first launch when switching, so they aren't
blockers.

Tested on Asa's Intel-based Mac with an Aug 3 PowerPC nightly and a July 8 Intel
build that I think Chase made.
(Assignee)

Updated

13 years ago
Assignee: nobody → joshmoz
(Assignee)

Comment 1

13 years ago
This happens to me when I switch between debug and optimized nightly builds with
the same profile, PPC builds on PPC. So I don't know that this has to do with
architecture issues.

And I dont' think chase made any Intel builds. AFAIK I am the only one who has
made any, and all the builds I would have put on Asa's machine are optimized.

Comment 2

13 years ago
Can you verify that the Intel & PPC builds were from the same branch?  A crash on first launch sounds like the mysterious extensions manager crash that I can't seem to find the bug for.  It happens everytime I switch from using FF 1.0.x to 1.5.x using an existing (even pristine) profile.

Comment 3

13 years ago
Can someone verify that this happens with two builds that come from the same branch at the same time, with the same debug/optimization settings?  And can that someone also provide a stack?
(Reporter)

Comment 4

13 years ago
Marking WFM because bug 325765 was just fixed and I never had a stack.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.