javascript error when clicking submit button

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: R.K.Aa., Unassigned)

Tracking

({qawanted, regression})

Trunk
x86
Windows XP
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050803
SeaMonkey/1.0a

Search buttons at vg.no no longer work.
Works OK in trunk Mozilla suite 2005070205

To reproduce:

Go to http://vg.no/
Top right there are two buttons below eachother, labeled "søk"
They normally submit the search term
(The search engine itself is down today due to problems after a power outage
some days agi, but that is irrelevant - just means the search will spin forever
without error message)
Enter some search term, hit "søk" button:

Result: Nada - just an error message:

Error: sok is not defined
Source File: javascript:sok.submit()
Line: 1

I reinstalled trunk 2005070205 to see if it worked there today, and it submitted
 OK. Installed Seamonkey 20050803 again and it fails again.
Regression between 2005073013 and 2005073111.
(Reporter)

Updated

13 years ago
Keywords: regression
(Reporter)

Comment 2

13 years ago
The only relevant checkin in that window was for bug 296639.
Depends on: 296639

Updated

13 years ago
Keywords: qawanted
Regressions should block the bug that caused them, not depend on it.
Blocks: 296639
No longer depends on: 296639
Works in todays nightly build. Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 5

12 years ago
FYI, this bug is fixed by bug 303420.
You need to log in before you can comment on or make changes to this bug.