Page content should not be theme-dependent

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: ehume, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050803 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050803 Firefox/1.0+

A change in theme can affect how a page is presented. For example, the atom feed
for Mozilla.org will show a button or a very thin line under "Article Length",
depending on the theme. 

Reproducible: Always

Steps to Reproduce:
1. Set Theme as default
2. Go to http://www.mozillazine.org/atom.xml
3. Set theme to SphereGnome

Actual Results:  
Instead of a button, a thin vertical line appears under "article length".

Expected Results:  
A button should appear under "Article Length", regardless of theme choice.

For a discussion, see the Mozillazine Forum topic Theme Changes sinces 1.0, from
here: http://forums.mozillazine.org/viewtopic.php?p=1650748#1650748

sharebird's screenshot is here:
http://img34.imageshack.us/img34/4730/feedview7rz.th.png

my theme's screenshot is here:

http://www.pshrink.com/firebird/Atom-SG.png
Feedview (like error pages) is themeable, by design. Also, it relies on the
theme widgets (buttons, textbox, etc.) look & feel, that also applies to xul
sliders.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.