bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

DBI Connect Error when using User Interface

RESOLVED INVALID

Status

()

Bugzilla
Bugzilla-General
--
trivial
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: David Button, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

I have completed the bugzilla installation, everything seems to be successful -
 except a problem with the Template perl module.

I open the main webpage, and attempt to follow a link such as "Search Existing 
bug reports" - or if I try to add a new account. The problem is that the 
following error appears:

DBI connect('host=localhost;database=bugs;port=3306','bugs',...) failed: Can't 
connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (13) 
at /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi/DBI.pm line 597
	DBI::__ANON__('undef', 'undef') called 
at /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi/DBI.pm line 648
	DBI::connect
('DBI', 'DBI:mysql:host=localhost;database=bugs;port=3306', '', '', 'HASH
(0x86ca9dc)') called at Bugzilla/DB.pm line 146
	Bugzilla::DB::_connect
('DBI:mysql:host=localhost;database=bugs;port=3306') called at Bugzilla/DB.pm 
line 138
	Bugzilla::DB::connect_main() called at Bugzilla.pm line 143
	Bugzilla::dbh('Bugzilla') called at Bugzilla.pm line 157
	Bugzilla::dbwritesallowed('Bugzilla') called at globals.pl line 355
	main::GetVersionTable() called at /var/www/html/bugzilla-
2.18.3/query.cgi line 210
 at Bugzilla/DB.pm line 146

I can access MySQL through the command line, and the server is certainly 
running.

When I install the perl Template module required by checksetup.pl, I get a 
problem when running the DB tests:

t/dbi............Use of uninitialized value in concatenation (.) or string at 
t/dbi.t line 64.
DBI connect failed

I re-ran the Template installation and turned off DBI tests, and then it 
passed, but the webpage fails.

I can run the testserver.pl script and everything works.



Reproducible: Always

Steps to Reproduce:
1.See "Details"
2.
3.

Actual Results:  
Error displayed in "Details" appeared on the webpage.

Expected Results:  
I'm guessing it should have displayed any bugs (none) - or allowed the 
creation of a new account.

This is running on Red Hat Fedora Core 3, using the built-in MySQL server with 
the install: Ver 11.18 Distrib 3.23.58. Additionally, apache httpd is the 
packaged version.
(Reporter)

Comment 1

13 years ago
It looks as if I've found a result for this - from a problem I had before.

I had a problem running the webpage before - and getting errors about how it 
couldn't load the XS.so library for the Template module. An answer I received 
was to not configure Stash::XS.

This allowed me to view the webpage - but has caused the problem described 
here.

A solution for the XS problem was suggested as disabling SELinux - which I 
have now tried and re-enabled Stash::XS. I can now use Bugzilla (I think).

However, I still get the problem with the perl module installation when 
testing DBI.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Severity: major → trivial
You need to log in before you can comment on or make changes to this bug.