Find-as-you-type highlights matches at bottom of screen (should scroll so match is in center of screen)

VERIFIED DUPLICATE of bug 263447

Status

()

Toolkit
Find Toolbar
VERIFIED DUPLICATE of bug 263447
13 years ago
9 years ago

People

(Reporter: unspammable, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Searching a page for an expression uses highlighting to bring focus to each
match. The problem is, especially with long pages, that when each match is
highlighted it's at the bottom of the screen, and then one has to scroll down to
read the entire sentence. It's better to highlight the match at the middle of
the screen.

To clarify, let's say that my browser window can show 30 lines of text and that
I'm viewing a page that has 100 lines. When I search for an expression whose
first occurance is on line 50, the search mechanism scrolls down to line 20 -
showing lines 20 - 50 and highlighting the match in the last line in the window.
Instead, the browser should scroll down to line 35, so that the match appears in
the center of the window. This has the additional advantage that each match is
highlighted at (roughly) the same place on screen (the middle thereof), and of
course one could easily read the context of the match.


Reproducible: Always

Updated

13 years ago
Summary: Find-as-you-type highlights matches at bottom of screen → Find-as-you-type highlights matches at bottom of screen (should scroll so match is in center of screen)
Created attachment 191679 [details]
screenshot

I see also very frequently this problem. 
The screenshot illustrates a similar problem in the opposite direction.

Comment 2

13 years ago
Related to Suite bug 78833 or bug 270124?

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 263447 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.