Closed Bug 303459 Opened 15 years ago Closed 15 years ago

when following a link to a page with a URL differing only in case of letters, pressing the back button acts as if pressing it twice

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 99091

People

(Reporter: sfid, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)

In the page http://en.wikipedia.org/wiki/Welfare_State (note the upper case S)
there is a link to the page http://en.wikipedia.org/wiki/Welfare_state (note the
lower case s). Pressing this link and then pressing the back button leads to the
page visited before http://en.wikipedia.org/wiki/Welfare_State. In the case of a
newly opened tab/window the back button remains gray.

Curiously, this is also the behavior in the newest version of Internet Explorer.
If this behavior is as expected then please delete this bug as soon as possible.

Reproducible: Always

Steps to Reproduce:
1. Visit http://en.wikipedia.org/wiki/Welfare_State
2. Press the link that leads to http://en.wikipedia.org/wiki/Welfare_state
3. Press the back button (alternatively, note that it is still grayed out)

Actual Results:  
Page http://en.wikipedia.org/wiki/Welfare_State is skipped in the browser
history, with http://en.wikipedia.org/wiki/Welfare_state in its place.

Expected Results:  
http://en.wikipedia.org/wiki/Welfare_State should remain in the browser history
regardless of the next page visited.
Fixed on the trunk, will be in 1.5

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.