stop building mozilla/widget/timer/src/windows/nsTimer.cpp on the mac

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
19 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: michael.j.lowe)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

looking at
http://tinderbox.mozilla.org/SeaMonkey/warn952120889.5858.html#ramiro, I see
that we are getting warning when building
mozilla/widget/timer/src/windows/nsTimer.cpp on the mac.

the problem is, we shouldn't be building that file on the mac, right?
<smfr> oh, i see what you mean. not the warning itself, but the fact that we are
building the windows code
<smfr> y'know, i suspect that lxr is messing up
this might not be michaels bug.  it might be a problem with how we generate the
warnings log file.

from sfraser:

"we're prolly just doing an lxr search on the filename to generate warnigns, and
it finds the windows file first. i'm pretty sure the mac project builds the
correct file.  so i wonder if that warning makes sense for the mac file"

slamm, is this your bug?
(Assignee)

Comment 2

19 years ago
The problem is in: 
http://lxr.mozilla.org/seamonkey/source/widget/timer/src/mac/nsTimer.cpp

The methods GetPriority & GetType should be returning values.  See below:

 92     virtual PRUint32 GetPriority() {};
 93     virtual void SetPriority(PRUint32 aPriority) {};
 94 
 95     virtual PRUint32 GetType() {};
 96     virtual void SetType(PRUint32 aType) {};

Comment 3

19 years ago
These methods are not called, because repeating timers are unimplemented on Mac 
(see bug 904). I'm working on that.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Comment 4

19 years ago
can one of you all verify this.  I'm not sure I'm teh right person to make that 
call.  thanks

Updated

16 years ago
Hardware: PC → Macintosh
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.