Clicking on url of a site requiring certificate - with an expired certificate on the browser creates a bizarre alert message

VERIFIED DUPLICATE of bug 288832

Status

()

VERIFIED DUPLICATE of bug 288832
14 years ago
11 years ago

People

(Reporter: karim.lakhani, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If a site requires certificates and the certificate has expired - a strange
alert message comes up when clicking on the :
xxx.xxx.edu has recieved an incorrect or unexpected message. Error Code: -12227 


Reproducible: Always

Steps to Reproduce:
1.Click on site url requiring certificate
2. xxx.xxx.edu has recieved an incorrect or unexpected message. Error Code: -12227 
 message comes on
3.

Actual Results:  
after clicking ok - stay on the same page

Expected Results:  
don't know

Comment 1

14 years ago
Related to/duplicate of Core bug 288832 and Core bug 124901 comment 4?
(Reporter)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 288832 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
V.Duplicate, per same error message.

*****

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032900 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

In the meantime, this has been fixed:
(Tested by setting my computer clock to a later year)
<https://bugzilla.mozilla.org/>
{{
Secure Connection Failed

bugzilla.mozilla.org uses an invalid security certificate.
The certificate expired on 10/12/2009 19:02.
(Error code: sec_error_expired_certificate)
}}
Status: RESOLVED → VERIFIED
Version: unspecified → 1.0 Branch
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.13) Gecko/20060414] (release) (W2Ksp4)

FWIW, I can't reproduce the error with SM v1.7.13,
which shows the expected "Server Certificate Expired" dialog.

(I don't know about FF v1.0.6;
steps are not very detailed, and there no image attached either.)
> FWIW, I can't reproduce the error with SM v1.7.13,

s/SM/MozillaAS/
You need to log in before you can comment on or make changes to this bug.