in plain text view, links with commas and spaces do not have whole link underlined & hyperlinked

RESOLVED DUPLICATE of bug 133016

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 133016
13 years ago
13 years ago

People

(Reporter: Rachel, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Expected results (full link):
1) http://www.domain.com/mypage.php?top=this is the problem
2) http://www.domain.com/mypage.php?top=this, is the problem

Actual results (part that is underlined/hyperlinked):
1) http://www.domain.com/mypage.php?top=this
2) http://www.domain.com/mypage.php?top=this

In actual TEXT, the whole link displays, but only the portion as listed above in
actual results is underlined and if you click on the link, the underlined
portion is the only part of the URL that your browser goes to.

In HTML view, the links display as expected, and go to the appropriate URL.

 





Reproducible: Always

Steps to Reproduce:
1. Open up email
2. Change to Text-view if necessary
3. Notice that the full link isn't underlined if it contains a space or comma

Actual Results:  
The full link wasn't underlined, and thus, not hyperlinkable.

Expected Results:  
Underlined and hyperlinked the FULL link.
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)

Oh my goodness, it's a problem in Firefox too.  When viewing this Bugzilla
report in Firefox, the links show up the same way.  So if you need a visual -
just open up in Firefox and you'll have one!
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)

I take that back about Firefox - it's a problem with the way the Bugzilla takes
my error report, and converts the links I type (as plain text) into HTML. 
Evidently the conversion of plain text links in Thunderbird and Bugzilla is done
the same way, and has a small problem with it. 

Comment 3

13 years ago
*** Bug 303591 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
This is a deliberate design decision, intended to avoid inadvertantly including 
text when a URL, such as http://mozilla.org, is included in text immediately 
followed by a comma, like right there in the above line.  When you're creating 
the text, you can force full recognition by enclosing the URL in angle-brackets:
  <http://www.domain.com/mypage.php?top=this,>

*** This bug has been marked as a duplicate of 133016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 5

13 years ago
*** Bug 311874 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.