Add search engine doesn't add browser.search.order entry to about:config

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Adam Guthrie, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Right now, we just include two entries for browser.search.order by default. When
a new engine is added nothing is updated in the prefs. Ideally, we need to add
new entries each time an engine is added to reflect the order of the search engines.

Steps to reproduce:
1. Add a new search engine.
2. Check in about:config under browser.search.order.*

There should be a new entry there reflecting where the new search engine was added.

Updated

12 years ago
Summary: Add search engine doen't add browser.search.order entry to about:config → Add search engine doesn't add browser.search.order entry to about:config
Why should there be a pref added there? It won't really do anything, and there
is no UI exposed for these prefs, so I don't see how it makes a difference.
Because of the way ordering was implemented, the pref is added now at shutdown.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.