All users were logged out of Bugzilla on October 13th, 2018

nsFileTransport::OpenInputStream takes 1.10 sec out of (9.9secs + dll loadtime)

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: dp, Assigned: warrensomebody)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Function				%	#calls	secs
=============================================================
nsFileTransport::OpenInputStream	100	51	1.10
  nsLocalFile::Exists			 89.89	51	0.99
  PR_ExitMonitor			 9.61	51	0.11

If I eliminate the Exists() call in nsFileTransport::OpenInputStream() I get 
about a 2 to 3 sec improvement in startup. Dont know if my tools are lying.
(Reporter)

Comment 1

19 years ago
warren, neeti has the fix in her tree and the timings. Hence I assigned the bug 
to her. You need to decide if this is ok to do.
Blocks: 7251
(Assignee)

Comment 2

19 years ago
I have a bug on this already, but can't seem to find it now. Let's see the fix.

Comment 3

19 years ago
*** Bug 30364 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
Created attachment 6640 [details] [diff] [review]
created an attachment for the fix

Comment 5

19 years ago
Reassigning to Warren to decide if the fix is ok.
Assignee: neeti → warren
(Assignee)

Comment 6

19 years ago
No way. I know this Exists call was added to fix another bug, I don't have time 
to do the archeology now to figure out the bug #.
(Assignee)

Updated

19 years ago
Target Milestone: --- → M17
(Assignee)

Comment 7

19 years ago
post-beta2
Target Milestone: M17 → M18
(Assignee)

Comment 8

19 years ago
This code has completely changed now. OpenInputStream now uses the nsIStreamIO's 
GetInputStream method. There still may be a problem here since 
nsFileIO::GetInputStream calls IsDirectory (which I believe also does a stat), 
but that can't be avoided. 

Marking invalid now.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
verified INVALID
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 7251
You need to log in before you can comment on or make changes to this bug.